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Welcome to DeskMate!

Your Getting Started magazine introduces you to the fascinating
world of DeskMate. If you are new to the DeskMate product, you
might have some of the following questions:

What is it? DeskMate combines several useful applications (soft-
ware programs) into one software package. These applications are
powerful tools to help you perform everyday tasks at home, school,
or work.

How do I use it? DeskMate is designed to be simple to use. The
screens look inviting, and moving around them is easy. Because all
of DeskMate's applications work in the same way, you can learn
about DeskMate's basic elements, and you're ready to work with any
application.

What do I use it for? With applications such as Address Book,
Calendar, Draw, Filer, Text, Worksheet, and so on, you can organize
your household items, the addresses/telephone numbers of all the
organizations you belong to, and even your finances. Type profes-
sional-looking letters, neighborhood newsletters, and school reports.
And don't forget to include some art you created using the Draw
application. DeskMate's uses are limited only by your imagination!

How Do I Learn to Use DeskMate?
Because people like to learn in different ways, your DeskMate
product comes with different types of instructional material. You
might want to browse through all of these pieces or find one that
best suits your needs.

• DeskMate... On Your Mark (or Putting It all Together)
— You will receive one of these items, depending on whether
you purchased DeskMate separately or it came with your new
Tandy computer. Use this documentation to get DeskMate set
up and ready to use.

• Getting Started — This magazine gives you a quick look at
DeskMate and each of its applications. Each application article
teaches you the basics of using that application.

2 Welcome to DeskMate!



DeskMate User's Reference — This manual gives you more
specific information about the applications. Each application
chapter gives you step-by-step instructions for each menu option
and also provides a guide to the tasks you can perform with that
application.

Beginner's Lessons — These are "on-the-screen" (on-line)
exercises that you can choose from the Teach Me box on
DeskMate's central screen (the desktop). Each application has
its own Beginner's Lesson that teaches you the basic concepts
of that application.

Help — DeskMate provides an extensive on-line help system
that is available from anywhere in DeskMate by pressing Fi.
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Getting Around in DeskMate

DeskMate's applications all use the same basic elements. When you
understand these elements and how to move around among them
and select them, you can quickly and easily use any of the applica-
tions.

When you start DeskMate, you see DeskMate's central screen, the
desktop.
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The boxes you see here on the
desktop are like "doors" to
DeskMate's applications. Ap-
plications help you perform
tasks like letter writing, record
keeping, and even budget plan-
ning.

Take a look at how easy it is to
move around the desktop.

Moving Around the
Desktop
On the desktop, notice that the
TEXT application on the screen
is highlighted. The highlight is
one way for you to see
DeskMate's cursor. The cursor
simply lets you know where you
are on the screen.

Sometimes the cursor appears as
a highlight, and sometimes it ap-
pears as a blinking vertical or
horizontal line.

Moving from door to door is
easy. All you do is press the TAB
key on your keyboard.

Go ahead and move around.
Press TAB a few times and watch
the cursor move around on the
screen.

Keep going. When the cursor
gets to the bottom of the screen,
it will start over again at the top.

If you accidentally move too far
and want to back up, simply
press SHIFT+TAB. (Hold down
SHIFT while pressing TAB.)
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Opening the "Doors"
To open a DeskMate "door" (or
application), simply move the
highlight to the application you
want to open, and then press
ENTER. If you have gone
through the Beginner's Lessons,
you have already opened one of
DeskMate's doors by selecting
the Teach Me box.

For practice, move the cursor
until you highlight the TEXT ap-
plication box and press ENTER.

Great! The Text application is
the part of DeskMate that makes
your letter or report writing
tasks easy. You'll learn more
about the Text application later.
For now, though, let's use this
application to become better ac-
quainted with DeskMate.

Telling DeskMate What
You Want
One of the things that makes
using DeskMate so easy is being
able to tell it what you want.

All of DeskMate's applications
have a menu bar. The menu
bar displays the menus that
you can use with the application
you're in. For example, Text has
six menus.

To "pull down" or open menus,
use the function keys on your
keyboard.

Go ahead and open the File
Menu by pressing the function
key F2.

Neu
Open.

Save
Merge
Page
Print
Print
Exit
Run. .

fo t)i

About

Edit F3[jTextF4 |Sear

as...

setup...

fom letter...
Esc

CIl

What you see is a list of op-
tions. Each menu has different
options to help you complete a
task.

Some menu options might be
shadowed. A shadowed option is
one that can't be used right now.

Want to look at some of the
other menus? Simply press the
function key (like F2 earlier) for
the menu you want to see.

If you have opened a menu and
then decide to do something

The function keys on
some computers
might be located on
the leftside of the key-
board.

Some options on the
menus have accelera-
tor keys. These keys
are listed to the right of
the option name. You
can press these keys
(or key combinations)
instead of selecting
the option.

Getting Around in DeskMate 7



else first, close the menu by
pressing the ESC key. Go ahead
and close the menu you've just
opened.

Open the File Menu (F2) again
to see how easy it is to select an
option on a menu. Simply press
the [ key until the option you
want is highlighted. Go ahead
and highlight the Run option. If
you move the highlight too far,
you can always press the t key
to back up. When the Run option
is highlighted, press ENTER to
select it. See how easy it is to use
DeskMate's menus?

When you select the Run option,
a dialog box appears on the
screen. A dialog box simply lets
you give DeskMate any addi-
tional information it needs to
complete a task. After you pro-
vide the information DeskMate
needs, you'll be on your way.

Program:

Data file:

H

1

Mi [Mill

You can move around the dialog
box like you move around on the
desktop. Simply press TAB to
move the cursor forward or
SHIFT+TAB to move it backward.
To learn more about dialog
boxes and how to use them, be
sure to see the box entitled
"Getting Around a Dialog Box"
in this article.

Ready to go back to home base
— the desktop? Press ESC and
watch how DeskMate "backs
up" until the desktop reappears.
(If you pressed any other keys
while you were in the Text ap-
plication, DeskMate might ask if
you want to save your docu-
ment. Simply press -» to under-
line NO, and press ENTER.)

Great! Now, there's one more
way for you to tell DeskMate
what you want. See the applica-
tion box on the desktop called
PROGRAMS? This kind of applica-
tion box is known as a list box.
Sometimes list boxes will ap-
pear in DeskMate so that you
can make a specific choice.

f PROGRAMS i\
ADDRESS. PDM
CALENDAR.PDH
DESKTOP.PDM
DRAW.PDN

It's easy to select from a list box.
Go ahead and try it. Move the
cursor to the PROGRAMS list box.
This list box contains a list of all
the DeskMate applications that
you can open. Now, simply press
the I key to highlight
FILER.PDM. See how the infor-
mation scrolls in the box so that
you can find your choice? To
select the highlighted applica-
tion, press ENTER.

You'll learn more about Filer
when you start exploring Desk-
Mate on your own. For now,
though, press ESC to go back to
the desktop.

Press ESC to remove
menus or dialog boxes
from the screen and
also to exit an applica-
tion and return to the
desktop.
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Now, you're ready to start exploring DeskMate's applications. There
are a couple of ways for you to do this. Either way is simple and
teaches the basics you need to know about an application. Choose
the way that is best for you.

Use DeskMate's
on-the-screen
Beginner's Lessons.

To Start the
Beginner's Lessons:

1. Press TAB until the Teach Me
box on the desktop is
highlighted.
Press ENTER.

3. Press J,to highlight a specific
lesson, and press ENTER.

2.

De'skMate Magazine

Turn to an application article in
this magazine, and step through
the tasks shown there. Write let-
ters, organize your address
book, create your own art work
and more!

Go ahead and explore. Your DeskMate magazine and Beginner's
Lessons are always available to help you get started. Also, remember
to press FI for help if you need it. (See the "Getting Help" article for
more information.)

Getting Around a Dialog Box

T a b ^
•

TAB moves the
cursor to the
next choice.

Space

£ 0 Line feed filter
^"Sinter PortslOLPTl OLPT2 OLP13 Arrow keys move the

cursor within a group
of buttons.

Space bar chooses
a button or check
box that the cursor
is on.

- Enter

Esc

Press ENTER to select
the OK button. Press ESC to select

the CANCEL button.
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Using a Mouse with DeskMate

When you are using DeskMate,
you can use a keyboard, a mouse
(or joystick), or both to move
around through DeskMate's ap-
plications. If you add a mouse to
your system, you'll find that this
handy tool speeds up your Desk-
Mate tasks considerably.

If you're going to use a mouse,
you must first "set it up" so that
DeskMate knows what kind of
mouse you are using. For in-
structions, refer to "Mouse Set-
tings" in the "Setup" section of
the "Accessories" article.

Making the Mouse
Work
Using a mouse makes moving
the cursor quick and easy. When
you use the keyboard to move
the cursor, you use the arrow
keys, TAB, ENTER, and the space
bar.

If you have a mouse, you can
move the cursor by simply
"pointing, clicking, and drag-
ging." You point to items on the
screen by rolling the mouse
around a flat surface. On the
screen, the mouse pointer
moves, showing you where you
are. Clicking (pressing and re-
leasing) the left mouse button
lets you either select an option
or button you are pointing at or
move the cursor to where you
are pointing. Dragging lets you
highlight information. To do
this, point to where you want to
start highlighting and hold
down the mouse button. While
holding down the button, move
the mouse until you highlight
all the information. Then, re-
lease the button.

The old adage "practice makes
perfect" is certainly true when
you use a mouse with DeskMate.
The more you experiment with
your mouse, the easier it is to
use.

We've provided a Techniques
Box that describes the basic
mouse movements. Also, in the
illustration below, you can see
how to point, click, and drag a
mouse.

You'll soon discover the advan-
tages of using a mouse with
DeskMate!
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Techniques Box

Mouse Basics
To Point: Move the mouse along a table top until the tip of
the pointer is where you want it on the screen.
To Click: Quickly press and release the left mouse button.
To Double Click: Click the left mouse button twice in rapid
succession.
To Drag: Hold down the left button while moving the mouse.
To SHIFT+Click: Hold down the SHIFT key and click the left
mouse button.
Use the Mouse with Arrow Icons
Arrow icons (graphic representation of an arrow) appear on
the menu bar, in list boxes, and other appropriate places in
some applications. Click on an arrow icon to move the cursor
in the direction of the arrow.

Use the Mouse with Menus
1. Point to the appropriate menu button on the menu bar.
2. Click the mouse button.

3. Point to the option you want to choose.
4. Double click the mouse button.

or
1. Point to the appropriate menu button on the menu bar.
2. Hold down the left mouse button, drag the mouse to

open the menu, and highlight the desired option.
3. Release the mouse button.

Use the Mouse with Dialog Boxes

• Point to the desired field or button, and click.
If you click on a field that requires that you type information,
the cursor appears there so that you can type.
If you click on a button, the button is chosen.
If you click on a check box, the box is checked (or un-
checked).

Use the Mouse to Highlight
1. Point to the place you want to begin highlighting.
2. Drag the pointer to the end of the information you want

to highlight.

Add a Mouse for "Point and Click" Convenience!
Add a mouse to your computer to make DeskMate even easier to use.
By simply rolling the mouse across your desk, you can make the
cursor fly from one menu to the next, and make selections with a
click of the mouse's button. A mouse also provides you with greatly
enhanced precision in DeskMate's Draw application.
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Getting Help

Although DeskMate is easy to
use, you might occasionally
need more specific information
than is covered in this maga-
zine. DeskMate's help system is
built into the software. This sys-
tem offers different levels of
help, from general to specific, to
meet any of your needs.

DeskMate's help is available
anywhere in DeskMate. Simply
press the FI key. Depending on
the screen you are using when
you press FI, or where you posi-
tion the cursor, information ap-
pears to assist you. Not only is
DeskMate's help easy to access,
but it is also easy to get out of
and right back to where you
were. Simply press ESC until you
exit Help.

General Help
General Help appears when you
press FI without selecting some-
thing specific on the screen.
General Help presents a group
of tasks and topics related to
your present location on the
screen. You can choose a spe-
cific box (task or topic) by using
the arrow keys to move the cur-
sor. The cursor on this screen is
the dotted box.

When you press Fi from the
desktop screen, specific informa-
tion about what is currently
highlighted on the screen ap-
pears. Pressing the Fi key again
accesses General Help.

Cursor

ENIER : tinre d t U i l s nn juEBtion ESC = Exit htlp

Task/Topic
boxes

If you don't see the task or topic you need on the first screen, you
can continue to display additional task/topic boxes by simply press-
ing Fl.

r
t

1
1 EHIER

Hlu Io I »si Help?
PrBEE EHIER

Whit i t an
application?

How do I run
an application?

: MOVE to nEXt pEstion

: Hare dstailE on pEstion

H.lp

K\ Hu do I novi V
1 around i n the DESKIOPT 1

• M
• «i» do I Ehmn

thE iisktop ilspliy!

B! M
exit DEEktiatt?

r . : Different pestionE

ESC = Exit bl ip

IfiB = HDVE to next quEEtion - . : OiffETEnt

ENIER = Hire detaih on (u ic t i in ESC = Exit help
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Once you see the task/topic box you want, press ENTER to display
specific information and instructions for that task or topic. Depend-
ing on the box you choose, DeskMate displays:
• Additional task/topic boxes

Howldo I USE Kelp? HQM do I novc
Press ENIER I around on the DESKIOPr

ou 0D I chanif
the desktop display';

Hnu do I run
an application?

IflB : HOVE U next question :; : Different pestions

ENIER = Hare details in question ESC - Exit help

• Step-by-step instruction boxes

. _r
j | (

1 IftB

1 ENIER

HDU in I run
an application box
fr-nn i.h* npRkr.np?

' ""iiJ
HDU do I run

an application
rn» r.hn TPM KnpKRn? 1

HOM in I run an
appllcatlnn that Is
nnr. nn r.hP crrppn?

•MMMJI
: HOVE tn nEKt t[UEEtion

- flare details on pesUon

r ; = Different jiestions

ESC = E«it help

irHDM 6a 1 mo an application

| H f f ChDPEE an application 1
^ B H I box on the Desktop.

If you wish,
H C > ^ | SElEct a liata f i l e .

Press EMIER
or

• rmiihlF Hlirk t.hp M D M . •

1 IAB - Hove to nEKt. peetiori

1 ENIER = flare details on quEKtinn

bnx l>nn tha UncktnpV

a
-• = DiffErEnt pest ions

ESC s Exit help

ffyou don 'f understand
a specific step, move
the cursor to the step
and press F I or ENTER.
Additional information
about the step appears
in the lower, left corner
of the screen.
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• Or, an information box

r
It
I
1 ENIER

Hoa in I vi ia
a l l nf m f i k s

anrl liMEUrteft?

Hun 9o I vita
ny applications
ml fpskrnp?

Hoa flD I aork with
f i les on ny ftisk?

: hove to next pesLion

= NOTE details pn BiiEslion

Haw Ho I aork
kith i l r tctor lEs

nn ny titifl

Hf Hoa ID I form •
U E K and nakl

lack>p«t

H | connoM
PROBLEHS

'. : Differcnt pEEf.ions

ESC = Exit help

Some programs you
might run under Desk-
Mate provide their own
help files. If you are
using one of these pro-
grams, you will not be
able to get help for dia-
log boxes, menus, or
menu options.

jfhe TREE option of the Uiew flenu
displays the directories that are on
the current drive.

Press the up or down arrow keys to
highlight a specific directory.

Bl-nore help Arrows-scroll UGBI-exit

The information box is the most specific help you can get on a task
or topic, but if you still need help, press Fi again. You will either see
additional information in the box or return to the first general
task/topic screen so that you can review the list of tasks and topics
again.

Quick Reference Help
Quick Reference Help gives you information about menu options,
dialog boxes, and message boxes. When one of these elements
appears on the screen, simply press Fl to access DeskMate's help.
Information about the option appears in the lower, left corner of the
screen as shown in these examples:

Menu option

C o p y . . .
D e l e t e . . .
R e n a m e . . .

Update screen Ctrl+U

Exit Esc

About..,

the RUN opliDn fron the File Menu
leaves the current application and
runs another application without
reluming lo the desktop.

If your application has a SADF

p=More help firrous=scroll
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Dialog box

ITT
Program:

Data fil«: [[

pt the PrograM: prompt, type the
pro gran naie. I he pro gran itane i s
the t i l e associated j i l h a DeskMatB
Dr DOS applicaliun.

fill Deskflale program filenames have

help frm>us=scroll exit

• M e s s a g e b o x

Free space Dn drive

1798144 bytes

Volume nane!

jThe information displayed i s the
anDuiit of free space in bytes
(characters) left Dn your disk, and
the disk name. [END]

=exit

Problem Solving Help
Problem Solving Help appears if you press FI when an error message
is displayed on the screen.

Fi lenaaie Error1

l i leiane basE more Mian 8 diaracters
filename must be in the following

format: BB1BBBBR XXX, where BBBBBBBB
i s the base of the filename and XXX
i s the extension.

The h&se rust be at least 1

This help is designed to give you information or instructions about
the error you made while performing a task. For example, if you
enter incorrect data in a dialog box, Problem Solving Help states
why your data is incorrect.
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DeskMate's Beginner's Lessons (Tutorials)
Beginner's Lessons for most of the DeskMate applications are avail-
able to teach you specifics about an application. However, you can
only run a lesson from the desktop. To access a lesson, use the arrow
keys to highlight the Teach Me box, and then press ENTER. A menu
appears listing the available lessons. To run a lesson, highlight it and
then press ENTER. Your step-by-step exercise begins.

To exit a lesson, press ESC. Press ENTER to confirm the exit and return
to the lesson menu. From there, you can select Exi t Thi s Lesson (or
press ESC) to return to the list of lessons. Press ESC again to return
to the desktop.

Techniques Box

Select Menu Options

1. Press a function key (F2-F10).
2. Press j to highlight the desired option.
3. Press ENTER.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• ENTER automatically selects OK.

• ESC automatically cancels the operation.

Cursor

Dotted box

Types of Help Boxes

Task/Topic Boxes

Step-by-step boxes

ENTER and FI Key

Enter

Fl

Selects a specific
Task/Topic box

Displays additional
Tasks/Topics boxes

Information box

'he Text application is a sinple
word processor that lets you prepare

erSi nenos, notes-, or anything
else «jou night nomait'j use a

writer to produce.

Fpiwre help farows-scroll Esc-exit
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Accessories

Change your screen colors, add up figures on a calculator, set an
alarm, plus much more.

DeskMate's accessories are
handy tools you can use from
anywhere in DeskMate. These
tools enhance DeskMate in the
same way that you use accesso-
ries to enhance your wardrobe
or home.

To access these tools or accesso-
ries, press FIO from anywhere in
DeskMate.

Setup

Spell Checker
Calculator
Phone List
Corkboard
Month
Alarm
To Bo List
Clipboard
Task Switch

The Accessory Menu (FIO) lists
DeskMate's accessories. Use J,or
f to highlight the accessory you
want to use, and then press
ENTER.

Setup lets you change
DeskMate's colors, set the date
and time, and specify any spe-
cial equipment you are using
(such as a modem, printer, or
mouse).

Spell Checker uses a 90,000-
word dictionary to check for
spelling and typing errors.

Calculator helps you tally up
that list of figures, just like a
hand-held calculator.

Phone List helps you access
phone numbers quickly and eas-

ily, and with a modem, you can
dial these numbers in a flash.

Corkboard lets you jot down
notes that you would normally
attach to your refrigerator.

Month lets you glance at a
monthly calendar.

Alarm flashes or sounds off to
remind you of appointments.

To Do List helps you keep
track of daily events.

Clipboard lets you see what
information is currently in the
clipboard and then move that
information into another appli-
cation.

Task Switch lets you switch
between DeskMate applica-
tions, or between DeskMate and
another software package.

When you receive DeskMate,
some accessories might be dis-
played on the desktop. You can
display the Corkboard, Month,
Phone List, or To Do List on the
desktop. Mix and match these
accessories to fit your needs.

See the "Desktop" article for in-
structions on how to install an
accessory on the desktop.

Let's look inside the various ac-
cessories so that you can see
how they work in DeskMate.

Attention Diskette Users:
If you are using diskettes to
run DeskMate, you might be
asked to insert another disk-
ette. Insert the requested
diskette and press ENTER.
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Some programs you run
under DeskMate might
provide a different Setup
accessory when you
press FIO than the one
that came with your Desk-
Mate version. If this is the
case, delete the Setup ac-
cessory (dmsetup.acc)
from the non-DeskMate
program's diskette or from
the directory where that
program is stored.

Setup
The Setup accessory lets you tell
DeskMate how it should look
and run. You can change your
screen colors, select a new sys-
tem date and time, and set up
your printer, mouse, or modem.

To select Setup, press FIO. Then
press I to highlight Setup, and
press ENTER.

The Setup screen shows you at
a glance how most of the op-
tions are currently set.

If you want to change one of the
options, select the option from
the Options Menu (F2). If you
are using a mouse and have pre-
viously set it up using the Mouse
Settings option, simply point to
the desired box on the Setup
screen and double click to select
the options that appear on the
screen.

Mouse Settings lets you se-
lect various pointing device op-
tions.

Communications Settings
lets you tell DeskMate what
kind of modem (or telecommu-
nications equipment) you are
using.

Date and Time lets you
change the current date and
time in DeskMate.

Colors lets you change
DeskMate's screen colors to any

combination that is pleasing to
your eyes.

In addition to the Setup options
that appear on the screen, there
are the Printer and Screen saver
options.

The Printer option lets you tell
DeskMate what type of printer
you are using.

The Screen saver option lets
you blacken your monitor
screen automatically after a cer-
tain amount of time has elapsed.

Communications Settings
When you select Communica-
tions from the Options Menu
(F2), you see the following dia-
log box:

Comunications Par

Ok
cconi
OCM2
Ocom
OC0B4

^ tiodens i

PLUS 128!

[HTERHM. 1288
PIUS 388 HAVES

Connection
D Modes
O Direct

COM Interrupt

<J!3«? OIKS

oim vim
Did! liMeout

Use the options on this dialog
box to tell DeskMate what kind
of communications equipment
you are using.

1. AttheCommunications Port
box, choose the port where
your modem is connected.
(Usually COM1 is used for an
external modem and COM2 is
used for an internal
modem. COM3 and COM4 are
used if you have an option
board with serial ports.)

2. At the Connection box,
choose Modem if you are
using a modem, or Di rect if
you are going to be con-
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nected directly to another
computer via cable without
using a modem.

3 . If you are using COM3 or
COM4, at the COM Interrupt
box, choose the appropriate
IRQ setting.

4 . If necessary, at the Dial
Timeout box, type the num-
ber of seconds you want
DeskMate to wait to com-
plete a call (before the
modem disconnects).

5 . If necessary, at the Modems
list box, highlight the
modem you are using.

If you have a Hayes modem,
choose Fast Hayes. If you expe-
rience problems with your
modem disconnecting, change
your modem selection to Hayes.

6. Press ENTER.

Colors
When you select Colors from
the Options Menu (F2), you see
the following dialog box:

iinMEHB'

Te*t Foregiw»d
i»r Backs™

IbraJtV Fn--4,,j

0

If you have a monitor that sup-
ports only one palette, such as a
monochrome monitor, the Col -
ors option is not available.

Use the options in this dialog
box to change DeskMate's col-
ors.

1. At the Palettes list box,
choose the section of your
screen (background or fore-
ground) you want to
change.

2 . Use the Red, Green, and
Blue bars to adjust the col-
ors and create the color you
want.

You can move the setting
right to add more of the
color or left to reduce the
amount of that color.

3 . If your monitor can detect
intensity settings, adjust the
Brightness bar to make the
colors brighter or dimmer.

4 . At the Change Colors:
prompt (only available in
the Draw application),
choose whether you want
DeskMate to save your
changes permanently or
only use them until you exit
Draw.

5 . If you want to see the
monochrome or color de-
fault settings, select either
MONOCHROME DEFAULT or
COLOR DEFAULT. (You might
wan t to use the mono-
chrome setting if you have
a monochrome monitor
that emulates color.)

6 . If you want to reset the col-
ors as they were when you
first entered the Setup ac-
cessory, select RESET.

7 . Press ENTER.
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Mouse Settings
When you select Mouse from the
Options Menu (F2), you see the
following dialog box:
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Use the options in this dialog
box to set up your mouse.

1. At the Pointing Device
box, choose the type of
pointing device you are
using. Choose:

Serial mouse for a serial-
type mouse.

Joystick for a joystick or
Tandy color mouse.

PS2 Compati bl e for a PS/2-
style mouse.

Other mouse for a previously
installed Microsoft-compat-
ible mouse driver in Desk-
Mate.

None if you don'twantto use
a mouse.

2. If you chose Serial for your
pointing device, at the Se-
r i a l Mouse Port box,
choose the appropriate set-
ting (usually COM1).

Be sure you select the correct
port if you have already installed
a serial mouse.

3. If you are using COM3 or
COM4, at the Port Interrupt
box, choose the appropriate
IRQ setting.

4. At the Double Click Speed
box, choose a comfortable
double click speed.

5. If necessary, double click on
the TEST button to test your
double click speed setting.

6. Press ENTER.

Date and Time
When you select Date and Time
from the Options Menu (F2), the
following dialog box appears:

At the Date: prompt, type a new
date using the format
mmddyyyy (mm = mqnth, dd =
day, yyyy = year).

At the Time: prompt, type the
new time, using the format
hh:mm:ss (hh = hour, mm =
minutes, ss = seconds). Then,
choose either AM or PM.



Printer Settings

When you select Printer from
the Options Menu (F2), you see
the following dialog box:

• Ho print.,-

• line feed fil ler

Get i m list of printers

'ran a floppy disk.

Printer Ports

D LPT1
OLPT2
OLPT3

Use the options on this dialog
box to set up your printer. Desk-
Mate refers to this printer infor-
mation each time you choose a
print option in DeskMate. If you
change printers, be sure to
change the printer information
in the Setup accessory.

1. At the Printers list box,
highlight the printer you
are using.

ASCI I is a generic printer driver
and should work with all print-
ers.

2 . If you are not going to use a
pr in ter , check the No
printer check box.

3 . At the Line feed f i l t e r
check box, check the box if
your printer does not auto-
matically do a carriage re-
turn at the end of a line.
Leave the box blank if your
printer does a carriage re-
turn.

For printers in IBM-mode, do not
check this box. For printers in
Tandy mode, check the box. If
your printer is double spacing or
printing lines on top of each
other, try changing this option.

4 . At the Printer Ports box,
choose the port where your
printer is connected.

5 . To add additional printers
to your list of printers, in-
sert the diskette containing
the printer information into
any drive, and select UP-
DATE.

6. Press ENTER.

Screen Saver

The Screen saver option is ben-
eficial if you leave your com-
puter and monitor on
constantly. DeskMate removes
the displayed screen, but you
can instantly recall it by press-
ing any key.

If you wish to leave your com-
puter on but not the monitor, you
can turn the monitor off and then
on again to redisplay the current
DeskMate screen.

When you select Screen saver
from the Options Menu (F2), the
following dialog box appears.

etuv Screen Saver I

The screen will never blacken

after a period of inactivity.

At the Blacken After list box,
highlight the amount of time
you would like your screen to
remain active before DeskMate
blackens it, and then press
ENTER.

If you don't want DeskMate to
blacken your screen, highlight
Never.

A message appears, telling you
that you can press any key to
return to your application after
your screen blackens. Press
ENTER to clear the message and
return to the Setup screen.
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Using Spell Checker
with Text

You can use spell Checker if
you're working in the Text appli-
cation by selecting Proof from
the Edit Menu. See the "Text"
article for more information.

Spell Checker
This accessory lets you check
your files or documents for mis-
spelled words. A built-in dictio-
nary checks your spelling, and if
it finds an error, it displays the
word and offers replacements.

When you select Spell checker
from the Accessory Menu (Fio),
you see the following screen:

Open the File or
Document You Want to
Check

The first thing you need to do is
choose the document you want
to check.

1. Select Open from the File
Menu (F2) on the Spell
Checker screen.

2 . Highlight the file you want
to check, or type the name
of the desired file at the
Open File: prompt.

3 . Press ENTER to begin the
Spell Checker procedure.

Check the File or
Document
After you open the file, Spell
Checker displays an unknown
word. The context in which the
word appears is shown directly
beneath the word.

If the unknown word is correct,
you can select Add to Diction-
ary from the Options Menu (F3)
to add the word to your User's
Dictionary.

The User's Dictionary lets you
add specific words that you often
use but are not contained in
DeskMate's main dictionary.

Correct an Incorrect Word

1. Either scroll through the
Replacements box and
highlight the correct word
or press SHIFT+TAB to move
the highlight to the Usage:
area and type the correct
word.

2. Press ENTER to accept the
word's context.

You can return to the original
word by selecting Restore con-
text on the Options Menu (F3).

Additional Spell Checker Tasks

Check Every Word You Type

• When you first open the Spell Checker accessory, select
Auto Proof from the Options Menu (F3).

When a word you type is not found, a beep sounds so that
you can check it.

Check a Specific Word as You Type
1. When you first open the Spell Checker accessory, select

Check Word from the Options Menu (F3).
2. At the Word to check: prompt, type the word you want to

check.
3. Press ENTER.

If the word is unknown, suggested alternatives are dis-
played. If the word is correctly spelled, a message is
displayed.

4. Press ESC.

Edit the User Dictionary
1. Select Ed i t from the Dictionary Menu (F4).
2. Choose the word you would like to delete using the

following keys:
PG UP displays the previous page of words.
PG DN displays the next page of words.
OK accepts the deletions (if any) you have made.
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Calculator
When you select the Cai cul ator
from the Accessory Menu (FIO),
DeskMate displays a "hand-
held" calculator on the screen.

Simply enter numbers using the
number keys on the keyboard,
and type the functions as they
appear on the calculator but-
tons. The calculator functions
are explained in the Calculator
Functions box if you need addi-
tional information.

To exit the Calculator, simply
press ESC.

Phone List
The Phone List accessory shows
telephone numbers that you
have entered in your Address
Book. This accessory is ideal for
jogging your memory, printing
a list of numbers, or if you have
a modem installed, DeskMate
will automatically dial for you.
When you select Phone List
from the Accessory Menu (Flo),
you see:

Cindy Criihh

Sylvia Jones

Linda Snelling

555-1BZS

555-B936

555-3859

s

CE

CA

+

_

X

/

%

M+

M-

MC

MR

Calculator Functions

Changes the sign of a
number.
Clears the current entry.
Clears all parts of the
calculator, except memory.
Adds the displayed num-
ber to the next one you
enter.
Subtracts the next number
you enter from the one
displayed.
Multiplies the displayed
number by the next one
you enter.
Divides the displayed
number by the next one
you enter.
Lets you use a percentage
in a calculation. For ex-
ample, entering 200 - 3%
produces the result of 200
minus percent (194).
Adds a number to the
amount in the calculator's
memory.
Subtracts a number from
the amount in the calcula-
tor's memory.
Clears the calculator's
memory.
Displays the calculator's
memory.

When you finish using this ac-
cessory, press ESC to exit.

Display Phone Numbers

To display work phone num-
bers, select Work phone from the
Number Menu (F3).

To display home phone num-
bers, select Home phone from the
Number Menu (F3).

You can always tell which num-
bers are displayed because an H
(home) or W (work) appears on
the phone list.

Make a Call
If you have connected an auto-
dial modem to your computer,
you can automatically dial any
phone number in Phone List.
Simply highlight the number
you want to call (using J,and f),
and then select Call from the
Number Menu (F3).

Be sure you have defined your
modem with the Setup
accessory's Communications op-
tion.

Print Your Phone List
To print a phone list, simply
display the list you want to print
(home or work phone num-
bers), and then select Print
from the Phone List Menu (F2).
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Corkboard
Use the Corkboard accessory as
you would a notepad. Your
notes are stored in the Cork-
board file, and you can refer to
them whenever you need them.

About the Corkboard
Screen
The Corkboard screen is very
simple:

Simply type your notes, and
then you can select PRINT to
print your notes or CLEAR to de-
lete them. To remove the Cork-
board accessory from your
screen, press ESC.

Month
When you select the Month ac-
cessory from the Accessory
Menu (FIO), you'll see the cur-
rent monthly calendar so that
you can quickly check a date.
The current month is deter-
mined by the date that appears
in the upper, left corner of your
DeskMate screen.

About the Month Screen

(larch 1998

5 i
12 13 14
19128T21
26 2? 28

22
17

23 i 24
30 31

To display the previous month,
press p. Press N to display the
next consecutive month.

Want to look a year ahead? Sim-
ply press CTRL+N to display the
same month next year. Or, press
CTRI+P to display the same
month in the previous year.

Press ESC to exit the accessory.

Key Functions for Corkboard

PG DX Moves cursor to bottom of
screen. Pressing again
displays the next screen.

PG UP Moves cursor to top of
screen. Pressing again
displays the previous
screen.

CTRL+HOME Moves cursor to
beginning of the text.

HOME Moves cursor to begin-
ning of the current line in
Corkboard.

END Moves cursor to end of
the current line in Cork-
board.

CRTL+END Moves cursor to end
of the text.

Alarm
To use the Alarm accessory, se-
lect Alarm from the Accessory
Menu (FIO). (Alarm only works
when you are running Desk-
Mate or DeskMate applica-
tions.) You see:

AlaiVCalBiidap Alams i This option controls vkttisi alams
Q Oft ! set In IMS lox and ii the calendar
G On ! progpan go off.

Suiek Man I i « : II : I Q «l

Hfssage' |flnakc up!!?

1. At the Alarm/Calendar
Alarms box, choose On or
Off to turn the alarm on or
off.
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When the alarm is turned on, the
available memory is decreased. If
you need additional memory
while running DeskMate, be sure
the Alarm is turned off.

2. At the Quick Alarm Time:
prompt, type an alarm time
using the hh:mm format (hh
= hour and mm = min-
utes) .

3 . Choose AM or PM.

4. At the Message: prompt,
you can type a description
of the event for which the
alarm is set.

When the alarm sounds,
you can select Al arm from
the F9 Menu and press
ENTER to display the mes-
sage.

5. Press ENTER.

To Do List
The To Do List accessory lets
you display an agenda box so
that you can monitor your day's
schedule demands "at a glance."
DeskMate's Calendar applica-
tion works hand-in-hand with
the To Do List accessory to give
you a quick look at your sched-
uled events, reminders, and an-
nual occasions.

To learn more about To Do List,
take a look at the sample screen
and description below:

Things Io Da

Independence Hay
flaUWs birthday
hake dental appt this month

5:68p Tanily picnic
9:9flp Fireworks display

The first thing that appears in a
To Do List (Things To Do
agenda) is any Calendar-de-
fined holidays (such as July 4th)
or annual occasions, such as a
birthday. If two or more annual
occasions occur on the same
date, they are displayed alpha-
betically.

After holidays and annual occa-
sions are displayed, the Things
To Do agenda displays remind-
ers. If two or more reminders
occur on the same date, they
appear alphabetically. On the
sample screen Make dental appt
this month is a reminder.

The last type of information that
appears on a Things To Do
agenda is events. Your day's
events are automatically re-
moved from the agenda as their
beginning times expire. When
DeskMate displays an event on
this agenda, only the start time
of the event is displayed.

If two or more events occur on
the same date, they are displayed
according to the start time.
Events (NOTESon the daily calen-
dar) that do not include a time
are listed before the events with
a time.

DeskMate's Things To Do
agenda can hold only 12 activi-
ties, so if you have 12 annual
occasions that are currently dis-
played on the agenda, there is
no room for reminders or
events. As activities originally
listed are deleted, additional
events, if any, will be displayed.

Display the Things
To Do Agenda
To see your daily agenda while
working anywhere within Desk-
Mate, simply select To Do List
from the Accessory Menu (FIO).
After viewing the agenda, press
ESC to remove it from the
screen.

You can also put the agenda on
your DeskMate desktop if there
is sufficient space. When there
is adequate room to display the
To Do List accessory, it will be
listed in the Display option on
the Desktop Menu (F7). Refer to
the "Desktop" article in this
magazine for further informa-
tion on rearranging your
desktop.
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Clipboard
The Clipboard accessory lets
you collect multiple pieces of
information so that you can
copy information in one appli-
cation and put it in another ap-
plication quickly and easily. For
example, any time you use the
Cut or Copy options in the Text
or Draw applications, the infor-
mation you cut or copy is stored
in the Clipboard accessory. You
can then use the Clipboard to
create a file in which to store
this information.

In addition to saving informa-
tion in the Clipboard, you can
retrieve, copy, or delete it as you
maintain and organize your in-
formation.

When you select Clipboard
from the Accessory Menu (FIO),
this screen appears:

Save Clipboard Files from
an Application

Follow the steps below to save
information on the Clipboard.

1. When you are in an applica-
tion and you have selected
the Cut or Copy option from
the Edit Menu (F3), select

the Cl i pboard option from
the Accessory Menu (FIO).

2. Select SAVE.

A dialog box appears.

If the Clipboard cannot save all
the information you have se-
lected, DeskMate will display a
message. Press ENTER to clear
the message.

3 . At the Name: prompt, type
the filename to which you
want to save the informa-
tion you have cut or copied.

4 . Press ENTER.

Notice that the filename ap-
pears on the Clipboard with the
application name in parenthe-
ses.

Copy Clipboard
Information into an
Application

1. Open the application you
want to move information
into.

2. Select Clipboard from the
Accessory Menu (FIO).

3. Highlight the Clipboard
entry you want to copy to
memory.

4. Select COPY.

5. Press ESC to remove the
Clipboard from the screen.

6. Move the cursor where you
want to place the clipboard
information.

7. Select Paste from the Edit
Menu (F3).

The Clipboard information ap-
pears at the cursor location.
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Delete a Clipboard Entry
1. Highlight the Clipboard

entry you want to delete.
2 . Select DELETE.

The highlighted entry is re-
moved from the Clipboard.

Clear the Entire Clipboard
• Select CLEAR.

All the entries on the Clipboard
are deleted.

Task Switch
The Task Switch accessory pro-
vides a way to place two Desk-
Mate applications or a
DeskMate application and an-
other software program in
memory. When you use Task
Switch, you can then toggle
back and forth between the ap-
plications or programs you have
set. You can also use Task
Switch to move between Desk-
Mate and MS-DOS.

When you store information on
diskette or access your disk
drives in any way, be sure that
you have the correct diskette (s)
in the drive(s) for the application
or program you are currently
using.

Switch Between
Programs or DeskMate
Applications
Select Task Switch while you
are in a program or application.
You automatically return to the
desktop. Then, simply select the
other application or program di-
rectly from the desktop. (If the
application is not displayed on
the desktop, you can use the File
Menu's (F2) Run option.)

Now, by selecting Task Switch
(or pressing ALT=), you can
move directly between the two
programs or applications.

To end a task, exit in the normal
manner. You will return to the
desktop. If you try to exit the
desktop and there is still a task
in memory, you will return to
that program. You can then exit
that application, and when you
return to the desktop, you can
exit DeskMate.

Switch Between
DeskMate and MS-DOS
To switch between any Desk-
Mate application (including the
desktop) and MS-DOS:

1. At the desktop or applica-
tion, select Task Switch
from the Accessory Menu
(FIO).

The Run dialog box appears.
(If you select Task Switch
from an application, you
must select Run from the
File Menu (F2) when the
desktop appears.)

2 . At the Program: prompt,
type command. com and press
ENTER.

The system prompt appears
on the screen.

You can now select Task Switch
(or press ALT=) to switch be-
tween MS-DOS and the desktop.

To cancel the task switch, sim-
ply type exit at the system
prompt and press ENTER. The
desktop is displayed. You can
access another application (or
program) or exit DeskMate. (If
there is still an application in
memory when you try to exit
DeskMate, enter the application
and exit normally and then exit
DeskMate.)

Task Switching Notes

• When you start a new program
or application, you might need
to change to the directory that
the new program uses.

• If you task switch to com-
mand.com, you must type exit
to return to the desktop.

• If you are using another graph-
ics program other than Desk-
Mate, task switching might not
occur. You might need to exit
the other program or applica-
tion so that DeskMate can be
restored.

Considerations When Running Task Switch

You cannot use Task Switch if you are running terminate and stay-resident
(always in memory) programs, such as Microsoft Windows, Sidekick, and
other similar programs.

You cannot use Task Switch with other software that requires you to reset
the computer in order to load.

You cannot use Task Switch with BASIC, using a mouse.

You cannot use Task Switch with programs that "take over" the keyboard.
You will know if your program does this by pressing the ALT= key sequence.
If nothing happens, your program controls the keyboard.
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Address Book

Address Book lets you group related addresses together into
specialized lists and use them for printing as well as reference.
Instead of having a different address book for each of your
activities,, you can keep allyour lists in DeskMate's Address Book.

Title bar

Index list
box

Status line

With DeskMate's Address Book
application, you can organize
all your addresses and phone
numbers in one place. You can
keep one master address list and
up to 25 separate, specialized
address lists — all in one elec-
tronic address book.

This article helps you get started
by showing you how to add,
update, and delete addresses in
one or more lists. In addition,
you'll get some ideas for setting
up your own lists. If you want
DeskMate to step you through
some Address Book exercises, be
sure to see the Address Book:
Organize Addresses Beginner's
Lesson.

Check Out the Ad-
dress Book Screen
The Address Book screen is re-
ally quite simple.

ddress
record

[ember Of
list box

Dates to Remember/Notes

You can access Address Book
from the desktop or from within
other DeskMate applications. If
you're not sure how to open an
application, be sure to see the
Techniques Box in this article
for more information.

Attention Diskette Users: If
you are using diskettes to run
DeskMate, you might be asked to
insert another DeskMate disk-
ette. Insert the requested disk-
ette and press ENTER.

See the Index list box on the left
side of your screen? This box
lists the addresses alphabeti-
cally by last name for the list you
are currently using.

If you want to know which list
you are using, take a look at the
title bar at the top of the
screen. In the middle of the title
bar, the name of the current list
appears after the words Address
Book. If you see AT 1, you are
looking at the master address
list.

Now, look at the right side of the
screen. You can see that the ad-
dress record is like an index
card. You can type your address
information on the address re-
cord.

See the Dates to Remem-
ber/Notes box on the screen?
You use this area to type birth-
day or anniversary dates, and
also add special information
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you want to remember about
the address listing.

Now take a look at the Member
Of list box. This box lets you
quickly see which specialized
address lists contain the cur-
rently displayed address.

At the bottom of the screen, the
status line lets you know how
many addresses are in the cur-
rent list and where the cursor is
on the screen. On this screen,
the cursor is on the Index list
box.

Go ahead and move the cursor
around the Address Book screen
by pressing TAB. Remember,
you can press FI for help any-
time.

Enter Addresses
When you first start using Ad-
dress Book, the View Menu's Al 1
option is already selected for
you. (Notice the word Al 1 in the
title bar.) Therefore, when you
add addresses, you are adding
them to your master address list
instead of a specialized list.

The first time you open Address
Book a blank record screen ap-
pears. Press TAB to move the
cursor to the Title field, and
then enter the address informa-
tion following Steps 2-4 below.
The next time you open Address
Book, the address record con-
tains information on the high-
lighted name in the Index list
box. To add new address re-
cords:

1. Select Add from the Address
Menu (F5).

2 . Type a courtesy title, such
as Mr., in the Ti tl e field.

BACKSPACE deletes the character
you typed to the left of the cur-
sor.
DELETE deletes the character you
typed to the right of the cursor.

3 . Press TAB to move to the
next field.

4 . Type the remaining address
information in the same
way.

You can change Birthday and
Anniversary to other date re-
minders if you'd like. Press TAB to
highlight the word, and then
simply type over it. If you don't
want to change these words,
press TAB to skip them.

When you finish entering the
address, you can store it using
the simple process explained in
the next section.

Store Addresses and
Add Additional
Addresses
To store the current address and
add another address, select Add
from the Address Menu (FS).
(Or, press CTRL+A, the acceler-
ator for Add.) As Address Book
displays another blank address
record, it stores the previous ad-
dress and adds it to the Index
list box.

You can enter addresses in any
order because Address Book au-
tomatically alphabetizes by last
name.
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When you finish adding ad-
dresses, select any available
menu option (other than an Edit
Menu (F3) option), and Address
Book stores the current address
and performs the action you
chose. For example, if you
choose Exit, Address Book
stores the last address you en-
tered and exits the application.

Delete an Address
from the Master List
When you use the Del ete option
on the Address Menu (F5), you
delete the address that is dis-
played on the screen from your
master address list.

1. Display the address you
want to delete.

2. Select Delete from the Ad-
dress Menu (F5). (Or, press
CTRL+D, the accelerator for
Delete.)

3. When asked if you're sure
you want to delete the rec-
ord, press ENTER.

Notice that the name disappears
from the Index list box.

Modify Address
Information
To change any information in
an address, simply highlight the
information you want to change
and type over it. Then, select
any menu option (other than an
Edit Menu (F3) option) to store
the changed address.

Create Additional
Lists
As you begin to organize your
electronic address book, you
might need to create some spe-

cialized lists in addition to the
master list DeskMate creates for
you. For example, you might
want to create an address list for
your Christmas cards, business
clients, or church members.

To create your own specialized
lists, do the following:

1. Select New from the List
Menu (F4).

A dialog box appears.

2 . Type the list (or group)
name.

3 . Press ENTER.

Address Book creates the list.
The list name in the title bar
changes, and an address record
is displayed for this new list.

You can add a few more ad-
dresses to this list, using the
procedures outlined in "Enter
Addresses." When you select
Al 1 from the View Menu, you'll
see that the addresses in this
specialized list are automati-
cally added to the index for your
master list.

View Address Lists
To view an address from your
master list, be sure the Al 1 op-
tion on the View Menu (F6) is
checked. Then, move the cursor
to the Index list box and use |
or jto highlight the appropriate
name. The address record infor-
mation changes as you high-
light different names in the list
box.

Remember SHIFT+TAB moves the
cursor backward.

To view your specialized ad-
dress list information, be sure
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the By l i s t option of the View
Menu (F6) is checked. Then,
highlight the list you want to
view, and press ENTER. The
name of the current list appears
in the title bar, and the Index
list box displays only the names
in that list.

You can easily view the address
records in an individual list by
moving the cursor to the Index
list box and using f or 1 to
highlight the appropriate name.
The address record information
changes as you highlight differ-
ent names in the list box.

Add Existing Ad-
dresses to Another
List
DeskMate makes it easy for you
to add existing address records
to specialized lists.

1. Display the address record
you want to add to a list.

2 . Select Add to 1 i st from the
Address Menu (FS).

3 . Highlight the list(s) to
which you want to add the
displayed address.

The Techniques Box in this arti-
cle has more information about
highlighting multiple lists.

4 . Press ENTER to add the ad-
dress to the list(s) you high-
lighted.

The Member Of list box indicates
that the displayed address is
now a member of the chosen
list(s).

Delete Addresses
from a Specialized
list
Deleting addresses from a spe-
cialized list is very similar to
adding addresses to different
lists. Simply display the address
you wish to delete, and then
select the Address Menu's De-
lete from l i s t option. Address
Book displays all available ad-
dress lists for that address re-
cord. Highlight the address
list(s) from which you want to
delete the address, and press
ENTER.

Do not confuse the Del ete from
1 i st option with the Del ete op-
tion. The Del ete option removes
the address from your master list.

Preview of Other Uses for Address Book
By now you have the gist of Address Book. You can use this
DeskMate application to keep all your address lists in one
location so that you can access the information quickly and
easily. Use your imagination and let DeskMate help you keep
everything organized.

With Address Book's advanced features, you can merge lists
together and print mailing labels and form letters (using the
Text Application). In addition, DeskMate's Phone List accessory
lets you access and dial the phone numbers stored in Address
Book quickly and easily. Be sure to see the Additional Address
Book Tasks box for more specific task instructions. Remember,
too, that you can press FI for DeskMate's help at any time.
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Techniques Box

Correct Typing Errors
BACKSPACE deletes the character immediately to the left of
the cursor.
DELETE deletes the character to the right of the cursor.

Edit Address Records
1. Highlight the appropriate information in the record.
2. Select Cut, Copy, or Clear from the Edit Menu (F3).
3. If you want to insert the highlighted information else-

where, position the cursor and select Paste from the Edit
Menu.
Note: To reinsert information that you removed using
Cut, Copy, or Clear, select the Undo option from the Edit
Menu (P3).

Exit the Application

• Press ESC to return to the desktop.

Highlight Multiple/Consecutive Usts
Consecutive lists:

• Press SHIFT+ I.
Non-consecutive lists:
1. Highlight the first list.
2. Press CTRL+jto move down the list box.
3. Press CTRL and the space bar on each list you want to

highlight.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press I until you highlight
Run, and press ENTER.

• A dialog box appears, and you can type the application
name at the Program: prompt, and if you wish, the name
of the file you want to open at the Data f i l e : prompt.
Press ENTER to open the application or file.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons
or check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a checked box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Select Menu Options
1. Press a function key (F2-F10).
2. Press i to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option (for exam-
ple, Copy on the Edit Menu (F3)).
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Additional Address Book Tasks
Dial a Phone Number

Note: You must have an auto-dial modem connected to
your computer to use this option.

1. Display the address containing the phone number you
want to dial.

2. Place the cursor on the work or home phone number
you want to call, or highlight a phone number in the Notes
field.

3. Select Cai 1 from the Address Menu (F5).
4. When the person you are calling answers the phone,

pick up the telephone receiver and select CANCEL to dis-
connect the modem from the line.

Find an Address or Group of Addresses
1. Select Al 1 from the View Menu (F6) to view all

addresses or By 1 i st from the View Menu to view a
specific list of addresses.

2. Select Find from the Address Menu (F5).
3. At the Search for: prompt, type the string of charac-

ters you want to find (like a name or street).
4. Select ENTER. If the address is found, it is displayed on

your screen.
Note: If Address Book cannot find the information you
specified, you see the message There are no matching
records in this 1 ist. Select OK to remove the message
from the screen.

5. To find the next occurrence of the same information,
select Find next from the Address Menu (F5).

Format Mailing Labels
Note: If you have a laser printer, Address Book takes into
account the printer's printable area, which is smaller
than the actual paper size.

1. Select Format labels from the File Menu (F2).
2. At the Sorted by prompt, choose Last name or Zip.
3. Choose the format that matches your mailing labels.

Note: In addition to formats for standard Radio Shack
mailing labels, an Other option is available. Use this
option if your labels do not match any of the given formats
or if you are not using a sheet-fed or continuous feed
printer. If you select this option, a dialog box appears so
that you can enter information about your labels.

4. Select ENTER.

Merge an Address List into the Current List
1. Select the By 1 i st option on the View Menu (F6).
2. Highlight the list into which you want to merge another

address list, and press ENTER
3. Select Merge from the List Menu (F4).
4. In the Merge from dialog box, highlight the name of the

list you want to merge into the current list.
5. Press ENTER.

Print Addresses/Mailing Labels
You can use the Print 1 abel s option on the File Menu (F2)
to print a list of addresses or to print mailing labels.

Note: If you are printing mailing labels, you must format
them before you print. See "Formatting Mailing Labels."

1. Select Al 1 from the View Menu (F6) to select all ad-
dresses or to select a specialized list, select By 1 i st
from the View Menu.

2. Feed the printing labels into the printer.
3. Select the Print labels option on the File Menu (F2).
4. At the Print to: prompt, choose the Printer button to

print mailing labels on paper, or choose the File
button to print the labels to a file.

5. Press ENTER.
Note: If you are using a continuous feed printer and the
message Are the labels correctly aligned? appears,
continue with Steps 6-10.

6. Choose NO to test label alignment.
7. At the Line number where f i r s t line should begin:

prompt, type a number in the range 0-6, specifying
which line the address has to begin on to be properly
aligned, and press ENTER.

8. Repeat Steps 6-7 as needed to adjust the vertical align-
ment.

9. If necessary, adjust the horizontal alignment by hand.
lO.When ready to print, choose YES at the Are the labels

correctly aligned? prompt.
Print Form Letters
You can use the Print form 1 etter option on the File Menu
(F2) to print form letters on paper, to the screen, or to a file.
1. Use the Text application to create the form letter.
2. Use Text's Add f ie ld option on the Layout Menu (F6) to

place the desired Address Book fields (Title, First,
Last, and so on) in the document.

3. In Address Book, select Al 1 from the View Menu (F6) to
view all addresses.

4. Select Print form let ter from the File Menu (F2).
5. In the Open File dialog box, highlight the Text file you

want to use, and press ENTER.
6. Highlight the list to which you want to send the form

letter, or highlight Al 1 to send the letter to all addresses,
and press ENTER.

7. Atthe Print to: prompt, choose printer, screen, or
f i l e , and press ENTER.

View a Single Address List
1. Select By 1 i st from the View Menu (F6).
2. Highlight the desired list.

3. Press ENTER.

View All Addresses
• Select Al 1 from the View Menu (F6).
View Address Book and Phone List Together
Address Book and the Phone List accessory access the
same information. Therefore, you can find any Address Book
phone number from anywhere in DeskMate simply by select-
ing Phone List from the Accessory Menu (Flo).
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Calendar

Attention Diskette Users:
If you are using diskettes to
run DeskMate, you might be
asked to insert another Desk-
Mate diskette. Insert the new
diskette and press ENTER.

Effective time management begins with an organized calendar.
DeskMate's Calendar application can help you schedule your valuable
time. Once you are organized, you'll feel like you've been granted
several more hours in each day!

Calendar lets you schedule your
appointments, meetings, and
events without the clutter of
bulletin boards and paper calen-
dars. You can tailor your calen-
dar to include dates of special
significance to you, such as
birthdays or anniversaries, and
even include daily reminders —
remember that dose of megavi-
tamins. Schedule events by the
date and time; Calendar can
even let you know if there's a
conflict in the schedule. Your
events can be scheduled to in-
clude an alarm that will alert
you when an engagement is
looming.

This article tells you how to start
Calendar and suggests some in-
teresting ways to use it. (Refer
to the Techniques Box in this
article for further information.)

When you first enter Calendar,
you see a monthly calendar
(named PERSONAL).

Diamond shapes indicate holi-
days and your own annual occa-
sions such as a birthday or
anniversary.

If you have questions about
Calendar, press Fl to use
DeskMate's extensive on-line
help or the Calendar tutorial.

Alarm — To set an alarm to remind you that an event is approaching, choose the
Alarm check box when you add an event. An alarm sounds at the event time. If
you want an alarm reminder before the event actually begins, set the starting time
earlier than the actual event. The Alarm function works only if you are using
DeskMate or a program that runs under the DeskMate Graphical Users Interface.
(Be sure you turn on the Alarm function from the Alarm accessory on the
Accessory Menu (Flo).
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The Conflicting
DatesDitemma
You're alone in the office at the
end of a long day. You've just
filtered through your mail and
noticed the concert tickets for
next month.

"Great!" you say aloud. The tick-
ets were hard to get, but you
managed, and now you can look
forward to a wonderful evening.

It's a long time between now
and the concert, and you surely
don't want to forget, so you de-
cide to add the event to your
PERSONAL calendar.

Scheduling an Event
1. At a monthly calendar,

press F6 to display the Event
Menu.

2. Press j,to highlight Add, and
then press ENTER.

A dialog box appears. Today's
date appears at the Event date:
prompt.

3. Press SHIFT+TAB to move
the cursor back to the Event
date: prompt, and type a
date approximately one
month from today using the
format mm/dd/yyyy.

4. At the Start time: prompt,
type 0800, the time the con-
cert begins.

5. Move the cursor to the
AM/PM buttons and use -» or
*- to underline the PM but-
ton. Then, press the space
bar.

6. At the End time: prompt,
type 1100, and then choose
the PM button.

This prompt is optional. Pressing
TAB lets you bypass the prompt.

7. At the Description:
prompt, type concert.

8. Press ENTER.

The monthly calendar reap-
pears, and a bar graph appears
on the day of the event to indi-
cate that you have something
scheduled. You can view this
event by highlighting the date
and pressing ENTER.

With the deed complete, you
leave the office and head for
home, confident that Desk-
Mate's Calendar won't let you
forget the special event.

Two weeks later, your son Tad
calls from school. He couldn't
wait to let you know that he
made the Varsity basketball
team! He tells you the date of his
first big game, and when you
hang up, smiling, you turn to
your DeskMate Calendar. This is
one date you don't want to for-
get. . .

Searching for a Date
1. To display your schedule for

the date of Tad's basketball
game, select Fi nd date from
the Search Menu (F5) on a
monthly calendar.

TAB moves the cursor for-
ward. SHIFT+TAB moves the
cursor backward.

mm = month, dd = day, and
— year. For example,

August 4, 1989 is typed as
08104/1989.

You can quickly access the
different calendars without
using the Display Menu (F4).
Refer to the Accelerator Key
Functions box in this article
for a list of keys.
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Before you print, be sure you
have told DeskMate the type
of printer you are using. For
more information, refer to the
"Accessories" article.

Annual occasions are saved
by the Calendar application
and will reappear year after
year. You can store up to 140
annual occasions.

Accelerator Key Functions

CTRL+A Add an event
CTRL+c Change an event on a

daily calendar
CTRL+F Find a specific event
CTRL+R Remove an event on a

daily calendar
CTRL+INS Copy a section of text
CTRL+D Display a daily calendar
CTRL+M Display a monthly

calendar
CTRL+N Find the next occurrence

of an event
CTRL+W Display a weekly

calendar
CTRL+Y Display a yearly

calendar
ENTER On a weekly calendar,

the event indicated by
the cursor
On a monthly calendar,
view the daily calendar
for the date indicated by
the cursor

DEL Clear highlighted text
SHIFT+DEL Cut a highlighted sec-

tion of text
SHIFT+INS Paste the contents of

the clipboard
ALT+N Move the cursor to the

next day, week, month,
or year

ALT+P Move the cursor to the
previous day, week,
month, or year

CTRL+HOME Move the cursor to
the beginning of a
daily calendar

CTRL+END Move the cursor to the
end of a daily calendar

2. Type the date of the game
(which happens to be the
same date you entered for
the concert).

3 . Press ENTER.

The monthly calendar for
that date appears.

4. To display the daily calen-
dar, press CTRi+D.

Whoops! The big basketball
game is the same evening as the
concert. Now what? You decide
to be the "model parent" and go
to your son's basketball game,
so you offer the concert tickets
to your boss.

When your boss, Ms. Snelling,
consults her DeskMate Calen-
dar, she discovers that the con-
cert date is also her nearly
forgotten wedding anniversary.
The concert tickets will be the
perfect gift for a perfect evening.
She smiles at you with gratitude
in her eyes, and you stroll back
to your office, confident that
you made the right decision.

Printing an Agenda
If you have a printer, you can
easily print out an agenda to
take with you to meetings or on
trips. You can print yearly,
monthly, or daily calendars.

Simply display the calendar for-
mat you want to print (daily,

monthly, or yearly), and select
Print from the File Menu (F2).
A dialog box appears so that you
can enter a range of dates.

A Calendar for All
Seasons
From the PERSONAL calendar,
you can add up to 19 additional
calendars using the New option
on the Calendars Menu. You
might want to create different
categories of calendars, for ex-
ample, a calendar for business
and one for personal events. Or,
you might even have separate
calendars for organizational
commitments, such as the Arts
Council, school board, and
church activities. You should be
able to cover all your activities
in twenty calendars (including
PERSONAL). If not, maybe it's
time to slow down.

To access the calendars you cre-
ate, first open the Calendar ap-
plication; you automatically go
to the PERSONAL calendar (or the
last calendar you used). Then,
use the Open option on the Cal-
endars Menu to display the list
of calendars you have created.

Highlight a calendar name, and
press ENTER to open that calen-
dar.

Now, take a few minutes to ex-
plore some of the other features
in Calendar. You might start by
adding a few annual occasions,
such as anniversaries or birth-
days.

When you're ready to exit Cal-
endar and return to the desktop,
select Exit from the File Menu
(F2) (or press ESC) . The desktop
screen appears.
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Preview of Other Uses for Calendar

You can create up to 20 individual calendars. Have a common
calendar for your family, with each family member having an
individual calendar. Keep track of programs you want to tape on
your VCR. Using your imagination, you can come up with lots of
ways to use Calendar.

Be sure to see the Additional Calendar Tasks box for more specific
task instructions. Remember, too, that you can press FI for
DeskMate's help at any time.

Opening a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER.

or

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press j,ur |ti l y ° u highlight
Run, and press ENTER.

A dialog box appears, and you can type the application
name at the Program: prompt. Press ENTER to select OK and
open the application.

Selecting Menu Options
1. Press a function key (F2-F10).
2. Press i to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option (for example,
Copy on the Edit Menu (F3).

Moving Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a check box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.
DELETE deletes the character to the right of the cursor.

Techniques Box

Moving the Cursor
Using the Keyboard:
Daily calendar — Press ior \to move the cursor one event
up or down on the list.
Weeky calendar — Press I or f to move the cursor to the
previous or next day of the week. Press «- or -» to move
the cursor backward or forward through the time slots (15
minutes).
To display time slots not currently on the screen, move the
cursor to the farthest point on the grid in the direction you
want to move, and press the appropriate arrow key.
Monthly calendar—Press ^or f to move the cursor to the
same day of the previous or next week. Press «- or -* to
move the cursor backward or forward one day.
Yearly calendar — Press I or f to move the cursor three
months backward or forward. Press *- or -» to move the
cursor to the previous or next month.
Using a Mouse:

Position the cursor anywhere on a calendar by pointing to
the desired location and clicking. You can also move the
cursor by clicking on the arrow buttons on the menu bar.
To display time slots on the weekly calendar not currently on
the screen, move the cursor to the farthest point on the grid
in the direction you want to move, and click on the appropri-
ate buttons.
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Additional Calendar Tasks

Add a Reminder
1. Select Reminder from the Event Menu (F6).
2. At the Description: prompt, type a reminder, using 60

3.
characters or fewer.
Press ENTER.

Add an Annual Occasion
1. Highlight (or display) the event date on a calendar.
2. Select Annual occasion from the Event Menu (F6).
3. At the Description: prompt, type the description, using

30 characters.
4. Press ENTER.

Add an Event
1. Highlight (or display) the event date on a calendar.
2. If you are using a weekly calendar, highlight the time slot

for the event.
3. Select Add from the Event Menu (F6).
4. AttheStart time: and End time: prompt, type the time

and choose AM or PM.
5. Atthe Descripton: prompt, type the description, using

120 characters or fewer.
6. Choose the Al arm check box if desired.
7. Press ENTER.

Change an Annual Occasion, Event, or Reminder
1. Highlight the Annual occasion, Reminder, or Event on a

daily calendar.
Note: You can also highlight an event on a weekly
calendar.

2. Select Change from the Event Menu (F6).
3. Type the new information.

4. Press ENTER.

Create a New Calendar
1. Select New from the Calendars Menu (F7).
2. Atthe Name: prompt, type a name, using 15 characters

or fewer.

Delete a Calendar
1. Select Delete from the Calendars Menu (F7).
2. Highlight the calendar you want to delete.
3. Press ENTER.

Delete an Annual Occasion, Event, or Reminder
1. Highlight the Annual occasion, Event, or Reminder on a

daily calendar.
2. Select Remove from the Event Menu (F6).
3. Choose This event only.
4. Press ENTER.

Display a Calendar
• Select Dai ly, Weekl y, Mont hi y or Yearl y from the Display

Menu (F4).

Find a Date
1. Select Find date from the Search Menu (F5).
2. At the Date: prompt, type the date you want to find.

3. Press ENTER.

Find Text
1. Select Fi nd from the Search Menu (F5).
2. Atthe Search for: prompt, type the text you want to find.
3. Atthe Start date: prompt, change the date if you want

to start the search at another date.
4. At the End date: prompt, change the date if you want to

end the search at another date.
5. Press ENTER.

Select Find next from the Search Menu (F5) to find
additional occurrences.

Find Today's Date

• Select Today's date from the Search Menu (F5).
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Desktop

The desktop is DeskMate's central screen, but it is also much more. Use
the options on the desktop to simplify the "housekeeping" chores for
your files.

The desktop's main job is to or-
ganize your DeskMate applica-
tions so that you can easily see
them and select them. But in
addition, the desktop also helps

Manage your files, directo-
ries, and disks

you perform many other special
tasks. For example, using the
desktop options, you can:

• Customize the screen so
that you can easily access
the programs you use most
frequently

Perform many of the com-
monly used MS-DOS com-
mands, such as copy, delete,
and format

• Install additional software
programs

When you first begin using
DeskMate, your desktop looks
like this:

Title bar—
displays the cur-
rent date and
time. It also
shows the appli-
cation you are
using.

Menu bar —
indicates the
menus that you
can choose by
pressing a func-
tion key. Each
menu contains
options you can
use to perform
tasks.

Programs box —
displays all applica-
tions on the current
drive or directory.

V
Application boxes —
let you choose a spe-
cific application to
run.

The desktop displays an application or program in a
box that is shaped as either a square or a button. If the
application lets you save files, a box is displayed on the
desktop, but if the application does not use files (for
example, Hangman), the application is displayed on the
desktop as a button.
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Customize Your
Desktop
As you use the desktop, you
might find that you need to re-
arrange the applications and
programs displayed there so
that you can more easily select
the ones you use most often.

Remove a box from the
desktop

Before you can display a new
program or application on the
desktop, you might need to
make room for it by removing
the application box (or button)
that represents the program or
application that you don't fre-
quently use. Removing an
application's box or button does
not erase it from DeskMate —
you can choose to redisplay it
later.

1. Press TAB until you high-
light the application box or
button you want to remove.

2. Press F7 to display the
Desktop Menu.

3. Press j until you highlight
Remove.

4. Press ENTER.

Display an application
box/button on the desktop

1. Press F7 to display the
Desktop Menu.

2. Press | until you highlight
Di spl ay, and press ENTER.

3. Use the arrow keys to high-
light the name of the appli-
cation or program you want
to display.

4. Choose the box size you
want to appear on the
desktop.

5. Press ENTER.

The desktop reappears, dis-
playing a dotted box.

6. Use the arrow keys to posi-
tion the box where you
want it to appear on the
desktop, and press ENTER.

Manage Your Files,
Directories, and Disks
The desktop provides many op-
tions for managing your
computer's files. These options
are simply some of the com-
monly used MS-DOS com-
mands. With these options, you
can quickly and efficiently orga-
nize your files and directories as
necessary.

Working with Files and
Directories

A file is simply a division of a
disk that contains specific infor-
mation — perhaps a program,
information you have created, or
just about anything. In Desk-
Mate, the files you will be most
aware of are those you create to
store data such as letters, re-
ports, and graphics.
A directory is a larger division of
a disk that can contain files,
other directories, or both. Usu-
ally, if you are using a diskette-
based system, it is not
necessary to create directories.
Instead, you might choose to
use a different diskette for each
group of files you create. How-
ever, if you use a hard disk you
have much more disk space and
will need to create directories to
keep your files organized.
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Change the Desktop View
There are three ways you can
look at the information on your
disk drive (s). The first method
is the Menus View, which is the
screen you see the first time you
use the desktop. This view
shows programs and, if applica-
ble, their associated files. The
second method, the Tree View,
shows a graphic tree represen-
tation of the directories on the
current drive. The third method,
the Files View, displays the tree
and the files for the current
drive or directory.

To change your desktop view:

• Select Menus, Tree, or Fi 1 es
from the View Menu (F5).

Change to a Different
Drive or Directory
If you want to see a list of the

files on another drive or in an-
other directory:

1. Select Change from the Di-
rectory Menu (F3).

A dialog box appears.
2. Choose the appropriate di-

rectory from the list box.
3. Select LOOK to view a list of

files without actually
changing to the directory.
Select OK to change to the
directory.

Format a Diskette
Before you can store data on a
diskette, you must prepare it for
the information. To do this:

1. Select Format from the Disk
Menu (F4).

A dialog box appears.

Techniques Box

Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.
DELETE deletes the character to the right of the cursor.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons
or check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a checked box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB
until you highlight the application, and then press
ENTER.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press J, until you highlight
Run, and press ENTER.

A dialog box appears, and you can type the application
name at the Program: prompt. If you know the name of the
file you want to open, type the name at the Data f i l e :
prompt. Press ENTER to open the application file.

Select Menu Options
1. Press a function key (F2-F10).
2. Press j t o highlight the desired option.
3. Press ENTER.
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2. At the Drive: prompt, type
the letter of the drive in
which you will put the disk-
ette to be formatted. (Use A:
for a one-drive system and
either A: or B: for a two-
drive system.)

Some of the information on the
screen might change when you
enter the drive letter. DeskMate
automatically determines the
type of drive you are using and
adjusts the type of information
you need to enter, if necessary.

3 . If the x.x inch diskette
box gives you a choice of
buttons, choose the one
that represents the type of
diskette you are using.

4 . (Optional) Place an x in the
Volume Label box if you
want to include a volume
label on your diskette.

5. (Optional) Choose Install
operating system to make
the diskette a system disk-
ette. (This is useful for other
Tandy 1000 computers
without MS-DOS built in.)

6. Press ENTER.

Follow the prompts to complete
the formatting process. When
you finish, the desktop reap-
pears.
Copy a Diskette
To make one or more copies of
a diskette:

1. Select Diskcopy from the
Disk Menu (F4).

A dialog box appears.

2. At the From: prompt, type
the letter of the drive that
will contain the diskette
you want to copy from.

3. At the To: prompt, type the
letter of the drive that will
contain the blank diskette
you want to copy to.

Type A: at the To: prompt if you
have only one drive. DeskMate
tells you when to switch disk-
ettes.

Copy a File
To copy a file to any directory on
any disk:
1. Select Copy from the File

Menu (F2).
A dialog box appears.

2. At the Copy from: prompt,
type the name of the file you
want to copy.

3. At the Copy to: prompt,
type the name you want to
give the copy, including the
drive and directory if neces-
sary.

Type B: at the Copy to: prompt
if you have only one drive. Desk-
Mate tells you when to switch
diskettes.

4. Press ENTER.

Delete a File
To create additional storage
space on a disk, you can delete
unwanted files.
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1. Insert the appropriate disk-
ette or change to the direc-
tory that contains the
unwanted file. (See
"Change to a Different
Drive or Directory.")

2. Select Del ete from the File
Menu (F2).

A dialog box appears.
3. Type the name of the file

you want to delete at the
Filename: prompt.

4. Press ENTER.

Install Other Software
Programs
Using the options on the
desktop, you can install other
software programs onto the
desktop. The desktop then pro-
vides a centralized location for
easy selection of all your pro-
grams.

Many of today's leading soft-
ware publishers are now using
DeskMate's User Interface to
give their programs the same
easy-to-use, friendly feel that
you enjoy with DeskMate. These
programs always display one of
the DeskMate User Interface
logos on the outside of the pack-
age.

DeskMate
User Interface by Tandy

DeskMate
User Interface by Tandy

Special Version for Childrens' Use

You can use the instructions in
"Install DeskMate User Interface
Programs" to install any of these
programs.

If, however, you have software
programs that don't use the
DeskMate User Interface, you
can still easily install these pro-
grams so that you can select
them from DeskMate's desktop.
Follow the instructions in "In-
stall Non-DeskMate Programs"
to install these programs.

Do not install other software
programs in the same directory
with DeskMate.

Install DeskMate User
Interface Programs
Because these programs have
special installation files, the in-
stallation process is automatic.

To install a DeskMate User In-
terface program, follow these
steps:

1. Insert the program's Install
diskette into Drive A.

2. From DeskMate's desktop,
press F7 to pull down the
Desktop Menu.

3. Press J, until you highlight
Instal 1, and press ENTER.

A dialog box appears.
4. Choose the box size you

want to appear on the
desktop.

5. Press ENTER.

The desktop reappears, dis-
playing a dotted box.

6. Use the arrow keys to posi-
tion the box where you
want it to appear on the
desktop, and press ENTER.

Diskette-Based Users

You might notice that some
DeskMate functions work differ-
ently after you install a new Desk-
Mate User Interface software
program. For example, you
might lose settings in the acces-
sories or help information might
be either unavailable or incorrect.

If these types of problems occur,
delete the following files from the
working copy of your new soft-
ware program diskette:

OMHELP.ACC
DMSETUP.ACC
DMSERV.ACC

Your DeskMate functions will
work normally.
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The install procedure continues
automatically. Simply follow
the prompts to complete the
procedure.

When the desktop reappears,
you can run the program by sim-
ply highlighting the box and
pressing ENTER.

Install Non-DeskMate
Programs

1. Press F7 to pull down the
Desktop Menu.

2. Press J, until you highlight
Create, and press ENTER.

A dialog box appears.

3 . At the Menu t i t l e : prompt,
type the title that you want
to appear on the desktop,
using 10 characters or
fewer.

4 . At the Program name:
prompt, type the command

you normally use to run the
program from MS-DOS.

5. (Optional) At the Data f i 1 e
extension: prompt, type
the extension you want to
assign to files created with
this program.

If your program does not create
files, leave this prompt blank.

6. (Optional) At the Start-up
directory: prompt, type
the path for the directory
you want to use when you
run this program.

A path tells DeskMate where to
find a file or directory. For exam-
ple, if you have a file called
DEARMOM in a subdirectory
(Personal) within a directory
(Letters) on your hard drive,
your path would be:
c:\letters\personal\dearmom.doc

7. Press ENTER.

Another dialog box appears.

8. Choose the list box size you
want to appear on the
desktop.

9. Press ENTER.

The desktop reappears, dis-
playing a dotted box.

10. Use the arrow keys to posi-
tion the box in a blank area
where you want it to appear
on the desktop, and press
ENTER.

You can now run your program
by simply highlighting the box
and pressing ENTER.

Hints on Using Quick Load

There is a box on your desktop known as the Quick Load box. This box appears in the upper right of your screen. Its title (and
shape) changes depending on the current directory or diskette you are using.

The uses for the box vary slightly, based on whether you are using a hard disk or diskette-based system.

Using Quick Load on a Hard Disk System
If you store lots of files for a specific application, you can
create a special directory within DeskMate for that applica-
tion. You can then use the Quick Load box to display the
application and its files on the desktop.
1. Create a new directory.
2. Change to that directory.
3. SelectCreate quick loadfromthe Desktop Menu (F7).

A dialog box appears.

4. Choose the application you want to assign to the Quick
Load box.

5. Press ENTER.
When you change to the new directory, the application and
its files appear in the Quick Load box.

Using Quick Load on a Diskette-Based System
If you use diskettes to run DeskMate, you might have too
many files for a specific application to store on a DeskMate
diskette. You can, however, create a special diskette to store
one specific application and its files. The application and
files will then appear in the Quick Load box when you insert
the diskette.

1. Copy the application (application.pdm) to a formatted
diskette.

2. Be sure that the designated drive contains the diskette.
3. Select Create quick load from the Desktop Menu (F7).

A dialog box appears.
4. Choose the application you want to assign to the Quick

Load box.
5. Press ENTER.
When you insert the diskette, the screen is updated and the
application and its files appear in the Quick Load box. Any
files you create for this application will be stored on the
diskette.

Using Quick Load with Programs that Use the DeskMate
User Interface
Tandy and other companies have programs especially writ-
ten to run with DeskMate. Most of these programs will auto-
matically appear in the Quick Load box when you insert the
program diskette and press CTRL+U to update the screen.
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Preview of Other Uses and Tasks
You've now seen many of the
basic tasks that the desktop can
help you with. Not only can it
help you organize your pro-
grams and information, but it
can also make some of the stan-

dard file/directory/disk "house-
keeping" chores much easier.

Be sure to refer to the "Addi-
tional Desktop Tasks" box to
learn about other ways to use

the desktop. Also, see the "Hints
on Using Quick Load" box for
information on another unique
desktop function.

Additional Desktop Tasks

Check Available Disk Storage Space
1. Select Get Info from the Disk Menu (F4).

A dialog box appears, displaying the amount of available
space and the disk volume name.

2. Press ENTER.

Check the File Size
1. Highlight a specific file on the desktop.
2. Select Get Info from the File Menu (F2).

A dialog box appears, displaying the file size and the date
you last changed the file.

3. Press ENTER.

Create a New Directory
1. Select Create from the Directory Menu (F3).

A dialog box appears.
2. At the Path: prompt, type the name of the new directory.

Note: If the new directory will be located on another disk
or in another directory, type the full path, using up to 64
characters. For example, to create a directory named
Letters on Drive B, type b: \ let ters.

3. Press ENTER.

Delete a Directory
1. Delete all the files from the directory you want to delete.

(See "Delete a File.")
2. Select Delete from the Directory Menu (F3).

A dialog box appears.
3. At the Path: prompt, type the name of the directory you

want to delete, including the drive name and any other
directories in the path.

4. Press ENTER.

Delete an Application Box or Button from DeskMate
Caution: This option erases an application or program so
that you can no longer display it on the desktop. If you will
later want to redisplay the box or button, use the Remove
option on the Desktop Menu.
1. Select Del ete from the Desktop Menu (F7).

A dialog box appears.

2.

3.

Highlight the name of the box or button you want to
delete.
Press ENTER.

Redefine a Box or Button
1.

2.

3.

4.

Select Redefine from the Desktop Menu (F7).
A dialog box appears.
Highlight the name of the box or button you want to
change.
Another dialog box appears.
Change any of the information in the dialog box.
Press ENTER.

Rename a File
1.

2.

3.

4.

5.

Be sure you are in the directory where the file resides (or
that the correct diskette is inserted).
Select Rename from the File Menu (F2).
A dialog box appears.
At the From: prompt, type the name of the file you want
to rename.
At the To: prompt, type the new filename.
Press ENTER.

Sort Files in the Tree View
1.

2.

Open a directory in the Tree View and display a list of its
files.
A dialog box appears.
Select the desired sort order from the Sort by Menu (F6).

• By name— alphabetically

• By type — alphabetically by extension name

• By date — from earliest to latest

• By si ze — smallest to largest

Update the Screen
1.

2.

Insert a new DeskMate diskette.
Select Update screen from the File Menu (F2).
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Draw

Using a mouse with the
Draw application pro-
vides you with more flexi-
bility.

Your Drawing Tools
You select your drawing tools
from the Tools Menu (F7).
Select
Lets you select an area of your
picture to move, copy, rotate,
flip, or delete.
Une
Draws a line between two
points.
Rectangle
Creates a box-shaped object.
Ellipse
Draws circular objects.
Text
Lets you insert letters, words,
and/or numbers on your draw-
ing.
Brush
Lets you "paint" with different
brush types.
Filled Brush
Fills an object you draw to its
outer boundaries with a pre-
scribed pattern.
Arc
Draws an arc.
Polyline
Draws an object of continuous
connecting lines.
Polygon
Draws an object of multiple
joining lines, then fills the
object.

Do you ever have trouble drawing a straight line? Using DeskMate's
Draw you can create pictures and designs by simply selecting a shape,
changing a color, or altering a design. You can add text and alter the
size of your drawing, too.

With Draw, you can design and
store colorful, artistic creations
using drawing tools such as
squares, circles, lines, and free-
hand styles. DeskMate's Draw
application also features differ-
ent styles of text and clip art —

Attention Diskette Users:
If you are using diskettes to run
DeskMate, you might be asked to
insert another diskette. Insert
the requested diskette and press
ENTER.

predrawn artwork you can use
in your pictures and designs.

If you want DeskMate to step
you through some Draw exer-
cises, be sure to see the Draw:
Draw Co lo r fu l P i c t u r e s
Beginner's Lesson.

The Birthday Card
You can access Draw from the
desktop or from within another
DeskMate application. If you're
not sure how to open an appli-
cation, be sure to see the Tech-
niques Box in this article for
more information.

When you open Draw, an empty
canvas appears. If you are not
using a mouse, the cursor ap-
pears in the upper, left corner of
the canvas. To draw on the can-
vas, you must select one draw-
ing tool at a time. Select a tool
from the Tools Menu (F7). A
check mark indicates the cur-
rently selected tool.

Let's experiment with Draw and
make a birthday card for Uncle
Wilbur's birthday. (This is num-
ber 83 for Uncle Wilbur!)

We'll step you through the di-
rections, but please feel free to
experiment with all the tools
and patterns. You'll soon be able
to see how easy it is to use your
creativity with Draw; whether
you're making birthday cards or
other graphics.
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Drawing the Card
First, the cake:
1. Select Rectangle from the

Tools Menu (F7).

2. Position the cursor to draw
the upper, left corner of the
cake. (To make this draw-
ing part of a card, draw the
cake on the left side of the
canvas.)

3 . Stretch the rectangle by
pulling it down and to the
right.

Now, a candle:

Using the same tool and same
technique, draw a candle on the
cake.

You've got to have
balloons:
1. Select Ellipse from the

Tools Menu (F7).

2. Position the cursor at the
center of the balloon.

3 . Stretch the balloon to the
desired size.

Let's paint and decorate:

1. Select Polyline from the
Tools Menu (F7).

2. Select the Brush option
from the Options Menu
(F6).

3. Adjust the brush setting to
draw thin lines. (We used
the default setting.)

For the plate:

Using the same tool and tech-
nique, draw the plate under the
cake.

4. Decorate the cake by draw-
ing connecting lines.

Select Brush from the Op-
tions Menu (F6), and
change the brush shape.
(We used the setting in the
top, left corner of the list.)

If you want to remove some-
thing you have drawn, use
the Select Tool to select a
specific part of your picture,
or use the Select al 1 option
on the Edit Menu (F3) to se-
lect the entire picture. You
can then select Cut from the
Edit Menu (F3) to remove the
selected area.

6. Select Brush from the Tools
Menu (F7), and "tie" strings
onto the balloons.

7. Again, using the same tool
and technique, add a
"flame" to the birthday can-
dle.

Writing the Card's
Message
Flipping the Picture

Because you plan to fold the
printed page into a card, the
cover should be upside down.

1. Select Sel ect al 1 from the
Edit Menu (F3).

Your entire picture is se-
lected.

2 . Select Flip vertical from
the Actions Menu (F4).

You see the picture upside
down.
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8. Type Uncle Wilbur, and
then press ENTER.

2.

Entering the Text

1. Select Text from the Op-
tions Menu (F6).

Leave all the fields set to the
defaults except Ju s t i f i c a -
tion. Under Jus t i f i ca t ion
choose center. Then, press
ENTER.

Select Text from the Tools
Menu (F7).

Select Half from the Zoom
Menu (F5).

3.

4.

The Zoom Menu contains op-
tions that allow you to "back
away" so that you can get a view
of your whole canvas. Use this
menu to also increase the focus
area (zoom in) on the canvas.

5. Move the cursor to the
lower, right quarter of the
canvas where you want to
type the greeting. Remem-
ber the text will be centered
as you type.

6. Type Happy, and then press
ENTER twice.

7. Type Birthday, and then
press ENTER twice.

Printing the Card
Using a dot matrix or laser
printer, you can print Uncle
Wilbur's card.

Before you print, be sure that you
have set up your printer prop-
erly, and that paper is loaded.
(See your printer manual if you
need more information.) Also, be
sure you have used the Setup
option on the Accessory Menu
(Fio) to tell DeskMate the type
of printer you are using. See the
"Accessories" article for more in-
formation.

1. Select Print from the File
Menu (F2).

A dialog box appears.

2. At the Print to: prompt,
choose the Printer button.

3. Press ENTER.

Folding the Card

After you print the card, fold it
like this:
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Preview of Other Uses for Draw
As you become comfortable with Draw and its special features, you
will find many uses for this application. You could use Draw to create
brochures, maps, greeting cards, and you might even make your own
Christmas cards.

In addition, as you become familiar with the Text application, you
can insert charts, graphs, and any other art. Be sure to see the
Additional Draw Tasks box for more specific task instructions. Also,
remember you can press Fi for DeskMate's help.

Techniques Box

Correct Typing Errors
BACKSPACE deletes the character immediately to the left of
the cursor.
DELETE deletes the character to the right of the cursor.

Edit Your Picture
1. Use Sel ect al 1 on the Edit Menu (F3) or the Sel ect tool

on the Tools Menu (F7) to select your picture or a portion
of it.

2. Select Cut, Copy, or Clear from the Edit Menu (F3).
3. If you want to insert the selected portion elsewhere,

position the cursor and select Paste from the Edit Menu
(F3).

Exit the Application

• Press ESC to return to the desktop.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a checked box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press j until you highlight
Run, and press ENTER.
A dialog box appears, and you can type the application
name at the Program: prompt, and if you wish, the name
of the file you want to open at the Data f i l e : prompt.
Press ENTER to open the application or file.

Select Menu Options
1. Press a function key (F2-F10).
2. Press I to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option (for example,
Copy on the Edit Menu (F3)).

Use of the Select Tool

• To use the Select tool, select it and position the cursor
outside the corner of the area you want to select. Then,
using the arrow keys or dragging the mouse, pull the
select border until it surrounds the picture you want to
select. Press ENTERor release the mouse button.

• To move selected items using a mouse, point to the
center of the selected area and drag it to the desired area
on the canvas.

• To move selected items using the keyboard, place the
cursor in the center of the selected area and press the
space bar. Then, use the arrow keys to move the selected
area to the desired location, and press the space bar
again.
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Additional Draw Tasks
Align objects
1. Use the Sel ect tool on the Tools Menu (F7) to select the

objects you want to align.
2. Select Al ign from the Actions Menu (F4).
3. Choose tops, bottoms, le f t sides, or right sides.
4. Press ENTER.

Break an Object Back into Pieces
1. Select the object.

2. Select Break object from the Actions Menu (F4).

Change Colors
1. Select Colors from the Options Menu (F6).
2. Choose one of the four attributes that you want to

change (Line, Text, Pattern Foreground, or Pattern
Background).

3. Choose one of the colors, and press ENTER.

Change the Canvas View
1. Select Two times or Four times from the Zoom Menu

(F5) for a magnified view, or select Hal f or Quarter for a
full view of the canvas.

2. Select Normal from the Zoom Menu (F5) to return to the
normal view.

Change Polygonal Shapes
1. Use Sel ect on the Tools Menu (F7) to select an object

created using the Polyi i ne or Polygon tool.
2. Select Add Corner, Move Corner, or Del ete Corner from

the Edit Menu (F3).
3. (Mouse) Point to the place where you want to add or

move a corner or to the corner you want to delete, and
click.
or
(Keyboard) To add or move a comer, move the cursor to
the appropriate place and press the space bar. You can
use the arrow keys to adjust the line. Press the space bar
again to finalize the change. To delete a corner, move the
cursor to the appropriate corner, and press the space bar
once.

Choose Keyboard or Mouse

• Select the Use keyboard or Use mouse option from the
Options Menu (F6) to quickly change the way you work
in Draw.

Choose the Line Weight and Style
1. Select Li ne from the Options Menu (F6).
2. At the Weight: prompt, choose the line weight you want

to use.
3. Atthe Style: prompt, choose the type of line you want

to use, and press ENTER.

Customize the Drawing Tools with a Fill Pattern
1. Select Patterns from the Options Menu (F6).
2. Choose the fill pattern you want to use, and press

ENTER.

Duplicate Part of a Picture on the Same Canvas
1. Select the picture, object, or element you want to copy.
2. Select Dupli cate from the Actions Menu (F4).
3. Move the picture to where you want it on the canvas.

Flip an Area Horizontally
1. Select the picture, object, or element you want to flip.
2. Select Flip horizontal from the Actions Menu (F4).

Insert a Picture into Another Application
1. Select the picture.
2. Select Copy or Cut from the Edit Menu (F3).
3. Exit Draw.
4. Open another application and file.
5. Position the cursor.
6. Select Paste from the Edit Menu (F3).

Insert Clip Art
1. Select Cl i p art from the Edit Menu (F3).

Note: You might be asked if you want to search the
system for the default file. Simply press ENTER.

2. Choose the picture you want to insert.
3. Select Paste from the Edit Menu (F3).

4. Move the art to where you want it on the canvas.

Make Picture Pieces an Object
1. Select all the elements you want to include in an object.
2. Select Ma ke obj ect from the the Actions Menu (F4).

Move an Item to the Front or Back of a Picture
1. Select the element you want to move.
2. Select Move to top or Move to Bottom from the Actions

Menu (F4).

Resize a Picture Using the Keyboard
1. Select the picture, object, or element you want to re-

size.
2. Select Resize from the Edit Menu (F3).
3. Use the arrow keys to resize the object.
4. Press the space bar when you are finished.

Rotate a Picture
1. Select the picture, object, or element you want to ro-

tate.
2. Select Rotate from the Actions Menu (F4).
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Filer
From attendance records to zucchini recipes, from auto maintenance
costs to family medical expenses, you can keep track of all kinds of
information when you get organized with DeskMate's Filer.

The Filer application is an all-
purpose tool for storing and re-
trieving information. With it,
you can quickly locate and up-
date practically any kind of in-
formation you can imagine.

Filer is very easy to use. You
simply open a Filer file and then
add records which you can think
of as electronic "index cards."
Each time you add a record,
Filer stores it in the file automat-
ically.

Filer comes with two files, invn-
tory.fil and carmaint.fil. These
two files are already created for
you so that you can set up inven-
tory records or car maintenance
records. You'll learn how to cre-
ate other Filer files later in this
article.

This article uses the sample file,
invntory.fil, to quickly guide you
through Filer's basic operation.
If you want DeskMate to step
you through some Filer exer-
cises, be sure to see the
Filer:Store & Retrieve Index
Cards Beginner's Lesson.

You can access Filer from the
desktop or from within another
DeskMate application. Refer to
the Techniques Box in this arti-
cle for further information.

Attention Diskette Users:
If you are using diskettes to run
DeskMate, you might be asked to
insert another diskette. Insert
the requested diskette and press
ENTER.

View Records in a File
The sample file, invntory.fil,
contains three records. Use
these three records to see how
Filer works. You can later create
your own inventory file to store
your household items. When
you open the file, you see its first
record.

To view the next record, press
CTRl+N (or point and click on
the Next button at the bottom of
the screen). You can move
through the records by using
the following keys or pointing
and clicking on the appropriate
button on the screen:

CTRI+F Displays the first re-
cord

CTRL+N Displays the next re-
cord

CTRL+P Displays the previous
record

CTRL+L Displays the last
record
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Add a Record
To see how Filer works, add a
new record to the sample file:

1. Select Add from the Records
Menu (F4).
A new, blank record ap-
pears.

2. Type CD PLAYER for the first
field.

3. Move to the next field by
pressing TAB.

Finish entering the information
as displayed in the following
sample record.

Change Information
in a Field
To change information that you
have already typed, move the
highlight to the appropriate
field. To replace all the informa-
tion in a field, you can then
either select Cl ear from the Edit
Menu (F3) to erase the informa-
tion or simply start typing at the
beginning of the field.

Remember, SHIFT+TAB moves
the highlight backward.

1. Move the highlight to the
appropriate field.

2. Use the arrow keys to move
the cursor to the informa-
tion that you need to
change.

3. Edit the field by either typ-
ing additional information
or using the BACKSPACE or
DELETE key.

Creating Your Own
Inventory File
Because you will want to use
Filer's invntory.fil to store your
own household items, you will
need to delete the sample re-
cords in invntory.fil. To delete
these records:

1. Display the first record in
the file.

2. Select Delete from the Re-
cords Menu (F4).

3. At the Delete record?
prompt, press ENTER.

4. Repeat these steps for each
record in the sample file.

You can now use this file to
store your own records. After
you enter records, you can
quickly find a specific record,
sort your records, or print one or
all of your records. For more
information about the tasks you
can perform, see the Additional
Filer Tasks box at the end of this
article.
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Create Additional
Filer Files
The screen layout that is dis-
played when you access invn-
tory.fil or carmaint.fil is called
the file's layout. The layout is
simply the format that appears
on the screen so that you can
enter information.

Before you can create additional
Filer files, you must have a lay-
out. There are two ways to cre-
ate this layout. You can either
copy an existing layout (for ex-
ample, invntory.fil's "index
card") or use DeskMate's Form
Setup application to create a
new, unique layout.

Copy a Layout
To copy an existing layout:

1. Open the file that contains
the layout you want to copy.

2. Select Copy layouts from
the File Menu (F2).

3. At the Copy to: prompt,
type a filename for the new
file, using eight characters
or less.

4. Press ENTER.

Filer creates the new file,
but the original file is still
displayed on the screen.

5. Select Open from the File
Menu (F2) to open the new
file.

Create a New, Unique
Layout
You can create layouts that fit
your most specific needs by
using the Form Setup applica-
tion. You can access this appli-
cation like any other DeskMate
application or directly from
Filer by selecting the Form Setup
option on the File Menu (F2).
Refer to the "Form Setup" arti-
cle in this magazine for instruc-
tions on creating your own
layouts.

Techniques Box

Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.
DELETE deletes the character to the right of the cursor.

Highlight Text in a Record
1. Use the arrow keys to move the cursor to the beginning

of the text you want to highlight.
2. Press SHIFT and the appropriate arrow key(s) to high-

light the text.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a check box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER. Select
the file you want to open in the Open File dialog box.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Press j , until you highlight Run and
press ENTER.
A dialog box appears and you can type the application
name at the Program: prompt, and, if you wish, the name
of the file you want to open at the Data f i l e : prompt.
Press ENTER to open the application. (If you do not
specify a data file name, select the file in the Open File
dialog box.)

Select Menu Options
1. Press a function key (F2-F10).
2. Press J,to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option (for example,
Copy on the Edit Menu (F3).
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Preview of Other Uses for Filer
You can use Filer to keep track of most any type of information. You
might want filer to keep a record of tax-deductible contributions,
utility bills, or medical expenses. You can also use Filer to keep track
of your collections — records, movies, stamps, rocks — the list is
almost limitless. Be sure to see the Additional Filer Tasks box for
more specific task instructions. Remember, too, that you can press
FI for DeskMate's help at any time.

Additional Filer Tasks

Format a Page Layout

1. Select Page setup from the File Menu (F2).
2. Change the desired options.

3. Press ENTER.

Copy a Record
1. Display the record you want to copy.
2. Select Copy from the Records Menu (F4).

The original record stays on the screen but is duplicated
in the file.

3. Select Next from the Records Menu (F4).
The new, copied record appears. Change the informa-
tion as necessary.

Count Records in a File
1. Select Count from the Records Menu (F4).

2. Press ENTER to remove the information from the screen.

Delete a Record
1. Display the record you want to delete.

2. Select Delete from the Records Menu (F4).

A dialog box appears, confirming that you want to delete
the record.

3. Press ENTER.

Find a Group of Records
1. Select Fi nd from the Records Menu (F4).

2. In the Fields list box, highlight the first field you want to
use to limit the search.

3. Choose the Operators: button that defines the relation-
ship between the field and the value you will add.

4. In the Val ue: field, type the value against which you
want the information in the selected field to be judged.

5. If necessary, establish additional search criteria by re-
peating Steps 2-4. (You can have up to five criteria.)

Print a Report
Note: This option prints your records using a report
layout you can design in the Form Setup application.

1. Select Print report from the File Menu (F2).
2. At the Print to: prompt, choose Screen, Printer, or

File.

3. Press ENTER.

Print Your Records
1. Select Pri nt record from the File Menu (F2).
2. At the Print to: prompt, choose Screen, Printer, or

File.

3. Press ENTER.

Sort Records
1. Select Sort from the Records Menu (F4).
2. Highlight the field you want to assign the highest

priority.

3. Select the Add to Sort button at the bottom of the box,
or press A1T+A.

4. Repeat Steps 2-3 to assign additional priorities (up to
five).

5. Press ENTER.

Switch to Form Setup from Filer
1. Select Form setup from the File Menu (F2).
2. Make any necessary changes to the layout. (See the

"Form Setup" article.)
3. Return to Filer by selecting Fi 1 er from the File Menu

(F2) in Form Setup.
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Form Setup
Question: What do you get when you cross a Filer with Form Setup?
Answer: A Flexible Filer!

A very flexible Filer because
with Form Setup you create the
files yourself from "scratch."
This means that you control
every aspect of your file layouts.

To begin with, you control the
size and location of the informa-
tion fields. But, there's even
more. For example, you can as-
sign field labels to later remind
you which information item to
enter in each field. You can even
include graphics from the Draw
application in your layouts.

To see the relationship between
Filer and Form Setup, open in-
vntory.fil in Filer. Display any
record. Then, switch to Form

Setup by selecting Form setup
from the File Menu (F2).

Notice that the Form Setup
menus replace the Filer menus.
You are still in the file, but now
you are looking at invntory.fil's
record layout.

Techniques Box
Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.

DELETE deletes the character to the right of the cursor.

Exit the Application

• Press ESC to return to the desktop.

Highlight Fields

• Use the arrow keys to position the cursor anywhere in a
field, and then press the space bar.

Move Around a Dialog Box

• TAB moves the cursor to the next field, (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a check box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER. Select
the file you want to open in the Open File dialog box.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Press J,until you highlight Run and
press ENTER.

A dialog box appears and you can type the application
name at the Program: prompt, and, if you wish, the name
of the file you want to open at the Data f i l e : prompt.
Press ENTER to open the application. (If you do not
specify a data file name, select the file in the Open File
dialog box.)

Select Menu Options
1. Press a function key (F2-F10).
2. Press j to highlight the desired option.

3. Press ENTER.
Note: Sometimes you must highlight information on the
screen before you can use a specific option (for example,
Copy on the Edit Menu (F3).
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you must always access a
file's report layout through the
file's record layout. Select
Define from the Report Menu
(F5,) whether you are creating
the report for the first time or
going back to make changes
to it.

Create a New Record
Layout
When you create a new file in
the Filer application, you might
want to design a specific record
layout that can handle the infor-
mation you are tracking in the
file.

1. Select New from the File
Menu (F2) in Form Setup.

A dialog box appears.

2. Type the filename for the
new file.

3. Press ENTER.

The application displays an
empty work area. This is where
you will create the file's record
layout.

To show you how to create a
record layout from scratch, let's
create a possible layout you
might want to use to track med-
ical expenses.

For example, if you wanted the
Filer application record to look
like this:

You would create this record
layout:

Patient

Lah lferk| .
IHitilK J .

Mil ChujtslTTj

IIIKSSQ 7 J

| / / ) late Ins, filed [77]

dunlins. dwmlFT]

The Record Menu (F4) in Form
Setup contains the Define op-
tion, which lets you create the
record layout. This option is au-
tomatically selected when you
use the New option to create a
new file. All you have to do is
begin adding fields.

Follow our example here to
learn how to use Form Setup.

1. Use the arrow keys to posi-
tion the cursor where you
want the first field (not the
field label) to appear. Then,
select the Add option from
the Field Menu (F6).

The field's first character slot ap-
pears.

Exact positioning of the fields is
not important. You can highlight
them and move them around,
using the Cut and Paste options
on the Edit Menu (F3).

2. Add character slots until the
field is the desired size.

Here's how: Press -» as
needed and then press
ENTER to end the field.
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Moving the cursor down and up
adds and deletes whole rows of
character slots. Moving the cur-
sor right and left adds and de-
letes whole columns. Every tenth
slot is shaded to aid you in count-
ing.

3 . A dialog box appears so that
you can specify the field at-
tributes. For example, for
the first field, specify the
attributes shown here.
Then, press ENTER.

Data Field Definition

Name: 1

Outlined: CD yes CJim

Data type: CHext Gn«aW

Label: Olef t CHop Chidden

4. Repeat Steps 1-3 to add
each of the remaining
fields. Follow these guide-
lines:

• Select number as the
data type for fields in
which you will enter
dollar amounts. Select
text as the data type
for all other fields.

• Select yes or no for out-
lining.

5. Insert the dollar sign ($)
and decimal point (.) for-
mat characters in the
amount fields. Also, you can
insert dashes (-) or slashes

00 in the appropriate slots
in the date field.

Here's how: Highlight the field,
and then select Format from the
Field Menu. Then, type the for-
mat characters in the appropri-
ate slots and press ENTER.
(Refer to the Techniques Box for
information on highlighting.)

Format characters are optional.
However, you must include a
decimal point in any numeric
field in which you plan to enter
decimal characters. Otherwise,
Filer lets you enter only whole
numbers. When you type num-
bers in a numeric field, the deci-
mal point is automatically
inserted.

6. Add the cosmetic text (Fam-
i ly Medical Expenses).

Here's how: Move the cursor to
where you want the text to
begin. Then, type the text and
press ENTER.

You can copy cosmetic text and
graphics using the Edit Menu's
(F3) Copy and Paste options
and include them at more than
one place on a layout. However,
you cannot copy a field because
each field can appear only once
on a layout.

Once you finish creating a re-
cord layout in Form Setup, you
can immediately return to Filer
to begin adding records. To do
so, select Fi 1 er from the File
Menu (F2).

Tips on Creating File
Layouts

You can save time by
designing layouts on paper
before creating them in Form
Setup. Be sure to leave
enough room for field labels
and outlining, if desired.

In addition to deleting and
moving a field, you can
change its size and attributes
(using the Field Menu's (16)
Si ze and Change options). Be
careful when editing a field
because any information al-
ready entered into this field
through Filer might be lost.
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Create a Report
Layout
Depending on the type of infor-
mation you are tracking, you
might want to be able to print a
report from your Filer file. You
can use Form Setup to create an
optional report layout in addi-
tion to the record layout.

To begin creating a new report
layout, you must first display
the record layout for the appro-
priate Filer file, and then select
Define from the Report Menu
(F5). A screen with four sections
appears.

If you had created the medical
expenses record layout de-
scribed earlier in this article,
you might want to design a re-
port that shows a specific mem-
ber of the family's medical
expenses since the beginning of
the year. For example:

Vearly fledical Expenses

Patient field
(from the Re-
cord Layout)

Current date

Header
Can include
cosmetic text,
graphics, and
the current
date.

Summary
Can perform
simple calcula
tions on se-
lected fields.

When the cursor is in one of these
sections, the title bar for that
section is unhighlighted.

Body —
Can include
fields from the
record layout,
graphics, and
cosmetic text.

Footer —
Can include
page number,
cosmetic text,
graphics, and
the current
date.

Cosmetic
Text

.Summary
field —
(based on
the Total
Charges
field from
the Record
Layout)

Refer to the Additional Form
Setup Tasks box for information
about the tasks you use to create
a report.

Once you have created a report
layout, you can print the report
using the Print report option
on the File Menu (F2) in the
Filer application.
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Preview of Other Form Setup Uses
Form Setup gives you total control over the design of your Filer files.
Regardless of what you decide to track using Filer, you can easily
use Form Setup to customize the screen for the exact information
you want to keep.

Be sure to see the Additonal Form Setup Tasks box for more specific
task instructions. Also, remember you can press FI for DeskMate's
help.

Add a Field to a Record Layout
1. Select Def i ne from the Record Menu (F4). (Automati-

cally selected when you enter Form Setup.)
2. Position the cursor where you want the field (not the

label).
3. Select Add from the Field Menu (F6).
4. Press -* until you insert the appropriate number of char-

acter slots, and then press ENTER.
5. At the Name: prompt, type the name for the field.
6. At the Outl ined: prompt, choose whether you want the

field outlined.
7. At the Data type: prompt, choose text or number to indi-

cate the type of information you will enter in the field.
8. At the Label: prompt, choose where you want the label

to appear.
9. Press ENTER.

Add a Field to a Report Layout
1. Select Define from the Report Menu (F5).
2. In the layout's body section, position the cursor where

you want the field's information to appear.
3. Select Add from the Field Menu (F6).
4. Highlight the name of the field you want at the specified

location.
5. Press ENTER.

Add a Summary Field to a Report Layout
1. Select Define from the Report Menu (F5).
2. In the layout's summary section, position the cursor

where you want the summary field to appear.
3. Select Summary from the Report Menu (F5).
4. In the Fi el ds list box, highlight the field on which you

want to base the summary.
5. At the Name: prompt, type a name for the summary field.
6. At the Outlined: prompt, choose whether you want the

field outlined.

Additional Form Setup Tasks

7. At the Data type: prompt,choose text or number to indi-
cate the type of information you will enter in the field.

8. At the Label: prompt, choose where you want the label
to appear.

9. Press ENTER.

Add cosmetic Text

• Position the cursor and type.

Add Format Characters
1. Highlight the field that will contain format characters

( - / $ • ) •

2. Select Format: from the Field Menu (F6).
3. Type the format character(s) in the appropriate charac-

ter slot(s).
4. Press ENTER.

Boldface Text
1. Highlight the text.
2. Select Bold from the Text Menu (F7).

Cancel Boldface or Underline
1. Highlight the text.
2. Select Plain from the Text Menu (F7).

Change Field Attributres
1. Highlight the field on a record or report layout whose

attributes you want to change.
2. Select Change from the Field Menu (F6).
3. Change the appropriate options.

4. Press ENTER.

Change the Size of a field
1. Highlight the field.
2. Select Size from the Field Menu (F6).
3. Press -» to add character slots.
4. Press ENTER.

(Continued on next page) >
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Additional Form Setup Tasks (Continued)

Change the Size of a Report Layout Section
1. Select Def i ne from the Report Menu (F5).
2. Position the cursor in the section you want to resize.
3. Select Resize section from the Report Menu (F5).
4. Press | to add lines or fto delete lines,
5. Press ENTER.

Copy a File's Layouts
1. Select Copy layouts from the File Menu (F2).
2. At the Copy to: prompt, type a filename.
3. Press ENTER.

Delete Information from a Layout
1. Highlight the information.
2 Select Clear from the Edit Menu (F3).

Insert a Date on a Report
1. Position the cursor in either the header or footer section

where you want the date to appear.
2. Select Today' s date from the Report Menu (F5).

Insert Page Numbers on a Report
1. Position the cursor in either the header or footer section

where you want the date to appears.
2. Select Page numberfrom the Report Menu (F5).

Place Graphics on a Layout
Using the Draw application, create the art.
Copy the art to the clipboard.
Open the appropriate record or report layout.
Position the cursor where the art will appear.

Print a Layout
1. Display the record or report layout you want to print.
2. Select Pri nt from the File Menu (F2).
3. Choose Screen, Printer, or File.
4. Press ENTER.

Resize a Picture
1. Highlight the art to be resized.
2. Select Size picture from the Edit Menu (F3).
3. Resize the box as you would in the Draw applicaiton.

Sort Records
1.
2.
3.

Select Sort from the Record Menu (F4).
Highlight the field you want to assign the highest priority.
Select Add to Sort at the bottom of the dialog box (or
press AlT+A).
Repeat Steps 2-3 to assign up to five fields.
Press ENTER.

4,

5.

Switch Between Layouts
To switch from a record layout to its report layout:

• Select Def i ne from the Report Menu (F5).

To switch from a report layout to its record layout:

• Select Def i ne from the Record Menu (F4).

Text a Report Layout
1. Select Show page from the Report Menu (F5).
2. Press ENTER.

Underline Text
1. Highlight the text.
2. Select Underl i ne from the Text Menu (F7).
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Hangman
Need a break from work? Here's a chance to have fun and improve
your vocabulary, too.

Hangman is a word game that
has remained popular for years
with young and old alike. With
DeskMate's version of Hang-
man, you'll enjoy a diversion
from work and chores — and
maybe add some words to your
vocabulary in the process.

You can access Hangman from
the desktop or from within an-
other DeskMate application. If
you're not sure how to open an
application, be sure to see the
Techniques Box in this article
for more information.

Attention Diskette Users: If
you are using diskettes to run
DeskMate, you might be asked to
insert another DeskMate disk-
ette. Insert the requested disk-
ette and press ENTER.

When you select Hangman, this
is the first thing you see:

Nunber of

LJ 1 O Z

Mopds per Cane

Wrong Guesses:

;§™

Players

O! t

O •0

n

This dialog box lets you design
your game by specifying the
number of players, how many
words you want to guess, and
how many wrong guesses you
can have before Hangman gets
you with his noose. When you

finish making your choices,
move the cursor to the OK button
and press ENTER.

Press TAB to move the cursor
(the underline) and press the
space bar to increase or decrease
your choices. If you need addi-
tional help setting up or playing
the game, be sure to press Fl for
DeskMate's help.

Another dialog box appears so
that you can type the names of
the players. When you're fin-
ished, select OK. The Hangman
screen appears.

Now you're ready to play!

The player whose name appears
in the Current Game box goes
first.

Type the letter you want to
guess.

If you are using a mouse, you can
point to a letter and click.

If the letter you choose is one of
the letters in the word, it ap-
pears in the appropriate box(es)
and is no longer available for
this game.
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If you try to exit during
the middle of a game,
you are asked if you
want to save the game.
If you choose YES, the
next time you select
Hangman, the program
asks if you want to con-
tinue the saved game.

If the letter you choose is not in
the word, part of the hangman
drawing appears, and you are
one step closer to being hanged!

Keep guessing letters unt i l you
guess the word (YOU'VE BEEN
PARDONED) or unti l the drawing
is comp le te (YOU'VE BEEN
HANGED).

The winner is the player who
makes the least number of
wrong choices.

A quick glance at the Score-
board will tell you everything
you need to know about the
score and who's next.

Good luck and have fun!

If at any time you want to
change the game or the players,
use the appropriate option on
the Players Menu (F3).

After each game, you'll be asked
if you want to play another
game. Simply select YES or NO.

When you are finished, press
ESC (or select Exit from the
Game Menu (F2)) to return to
the desktop.

Techniques Box

Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.
DELETE deletes the character to the right of the cursor.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a check box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press J,until you highlight Run
and press ENTER.

A dialog box appears and you can type the application
name at the Program: prompt. Press ENTER to open the
application.

Select Menu Options
1. Press a function key (F2-F1O).
2. Press J,to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option.
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Telecom

Your computer can become a wonderful communications tool with
Telecom. Using your telephone and a modem, you can communicate
with an information service, send that special computer game to a
friend, or just keep in contact.

Telecom makes communicating
with another computer simple
by letting you build and save an
automatic log-on (autolog)
"connection" file.

Before you use Telecom, be sure
to enter the communications
settings that DeskMate needs to
connect you to another source.
You enter these settings using
the Setup option on the Acces-
sory Menu (FIO). For more in-
formation about using Setup,
see the "Accessories" article in
this magazine.

You can access Telecom from
the desktop or from another
DeskMate application. Refer to
the Techniques Box in this arti-
cle for further information.

Attention Diskette Users:
If you are using diskettes to run
DeskMate, you might be asked to
insert another DeskMate disk-
ette. Insert the requested disk-
ette and press ENTER.

Before You Set Up an
Autolog File
When setting up an autolog file,
you must have specific informa-
tion (such as word length, par-
ity, and so on) about the host
(the computer you want to com-
municate with). Be sure you
have this information before
setting up your file.

Here's a sample autolog file that
contains some of the common
commands you'll use to set up
your own autolog files:

ftwumisj

S
c
s
II
1

!l
111

i l l for

Parameters

3M, 8, «, 1 M

fisiaz
Br«ak-Seqiiewe
" login" , 38 seconds

Let's go through the process of
setting up this file.

You will probably be using
a modem with Telecom. It
is possible, however, to
use Telecom without a
modem if you are directly
connected to another com-
puter.

A very popular telecommunica-
tions service is CompuServe.
The following autolog file pro-
vides a pattern you can follow to
access this service. You will
need to enter your own modem
baud rate, the local Compu-
Serve number and your ID num-
ber and password assigned by
CompuServe.

Set
Call

Wait
Send
Wait for
Send

Wait for
Send

1200,7,E,1,ON
(Local CompuServe
number)
3 seconds
" ~ C"
":",30 seconds
(ID number,
for example
"70007,xxxx~M)
":",30 seconds
(Password, for example
"PASS*WORD'-M"

There are many other services
available. Information from these
services will provide the parame-
ters you need to setup other au-
tolog files.
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Set Up a Sample Autolog
File

Remember that some of the op-
tions you choose when creating
your own autolog files will de-
pend on the requirements of the
host computer. The autolog file
you set up with the steps below
is a sample to help you get ac-
quainted with the procedure. As
you create your own autolog
files, you can add as many com-
mands as you want to make
your login procedures quick and
automatic. Remember, too, that
you can press FI for DeskMate's
help.

Set the Communication
Parameters for the
Sample File

1. Select Set from the Com-
mands Menu (F3).

A dialog box appears.

2. At the Baud prompt, choose
300, to tell Telecom how
fast to transmit information
to the other system.

3 . At the Word Length prompt,
choose 8 to tell Telecom
how the transmitted char-
acters are formed.

4. At the P a r i t y prompt,
choose None to tell Telecom
how to code and decode in-
formation passed on be-
tween the two computers.

5. At the Stop Bits prompt,
choose 1 to tell Telecom
how to check transmitted
characters.

6. At the Flow control
(Xon/Xof f) prompt, choose
On to tell Telecom how to
monitor transmissions be-
tween computers.

7. For the sample autolog file
we are creating, none of the
other options need to be
chosen, so press ENTER.

You can choose any of these re-
maining check boxes as neces-
sary when you are creating your
own autolog files.

Add a Call Command to
the Sample File

You can specify the number you
want to call with this file so that
you won't have to enter that
information manually each time
you use this autolog file.

1. Select Cal 1 from the Com-
mands Menu (F3).

A dialog box appears.
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2. At the Phone number:
prompt, type 555-1212 (the
host's telephone number).

If you have an auto-dial
modem, the number is di-
aled automatically when
you execute the file. For
other modems, you must
manually dial the host's
telephone number immedi-
ately before executing the
autolog file.

3. Press ENTER.

Add a Send Command to
the Sample File
In the file we are creating, the
host computer needs a break
sequence to get its attention.
Using the Commands Menu's
(F3) Send option, you can send
a break sequence or a string of
characters to the host computer
using your autolog file.

1. Select Send from the Com-
mands Menu (F3).

A dialog box appears.

2. Press J, to move the cursor
to the Send break sequence
button, and press the space
bar.

3. Press ENTER to complete the
task.

Add a Wait Command to
the Sample File
Sometimes when you are log-
ging onto a host computer, you
need to wait for the host to pick
up your call. You can add a wait
command to your autolog file to
help make your login procedure
easier.

For this file, let's say the host
gives you a "login" message
when you are logged onto the
host.

1. Select Wait from the Com-
mands Menu (F3).
A dialog box appears.

2. Choose the Wait for
string: button and then
type login in the field
below the button.

3 . At the Timeout: prompt,
type 30 so Telecom will wait
30 seconds for the "login"
message.

4. Press ENTER.

Execute an Open Autolog
File
To execute an open autolog file,
such as this one, simply select
Execute from the Commands
Menu (F3). The terminal screen
appears, and DeskMate per-
forms the autolog tasks you
have outlined in your file.

Disconnect the Telephone
Line
When you finish communica-
ting with the host computer,
simply select Disconnect from
the Options Menu (F5) to dis-
connect the call.

You can also disconnect auto-
matically by pressing ESC at any
time. You return to the Com-
mands screen. Press ESC again
to return to the desktop.

Telecom 65



Preview of Other Telecom Uses
You can use the Telecom application to communicate with outside
news services, bulletin boards, or other host systems. You can also
communicate with other computers directly (via cable) or through
a modem.

In addition to the autolog file commands we have already intro-
duced, you can include transfer commands in your autolog files. Or,
if you prefer, you can transfer information manually without using
an autolog file.

Also, as you create autolog files, and they need to be changed, you
can insert or delete command lines in these files.

Another special Telecom feature is the buffer. You can store trans-
mitted information in the buffer and then copy it to a file or print it
as needed.

Be sure to see the Additional Telecom Tasks box for more specific
task instructions. Also, remember to press FI for DeskMate help.

Techniques Box

Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.
DELETE deletes the character to the right of the cursor.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a check box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press iuntil you highlight Run,
and press ENTER.
A dialog box appears and you can type the application
name at the Program: prompt and, if you wish, the name
of the file you want to open at the Data f i l e : prompt.
Press ENTER to select OK and open the application or file.

Selecting Menu Options
1. Press a function key (F2-F10).
2. Press ^to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option.
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Additional Telecom Tasks

Add a Transfer Command to an Autolog File
1. Select Transfer from the Commands Menu (F3).
2. Highlight the name of the file you want to transfer.
3. Choose Send to transfer a file from your computer to the

host or Receive to transfer a file from the host to your
computer.

4. Choose Xmodem to use the special file transfer protocol or
ASCII to use the ASCII file transfer protocol.

5. If you chose ASCII, choose the appropriate option:
Add 1 i ne feed after carri age return to add a line feed
each time Telecom sends (or receives) a carriage return
character.
Strip 1 ine feed after carriage return to take out line
feeds after carriage return characters.
Straight ASCII transfer to strip all non-ASCII codes
from the file.

6. If necessary, at the Command to start transfer: prompt,
type the command needed to indicate to the host that
your computer is ready to receive the ASCII file.

7. Choose Add carri age return to add a carriage return for
the command in Step 6 if required.

8. Atthe Timeout: prompt, type the number of seconds
you want Telecom to wait.

9. Press ENTER.

Delete a Line from an Autolog File
1. Position the cursor in the line you want to delete.

2. Select Delete from the Commands Menu (F3).

Delete the Buffer Contents
1. Select Clear from the Buffer Menu (F4).

Note: If you have not saved the contents of the buffer
since you added the last character, DeskMate will ask if
you want to save the changes. To save the contents into
a file before you clear the buffer, continue with Step 2. To
delete the contents of the buffer without saving them,
choose NO. The contents of the buffer are deleted.

2. Select YES, NO, or CANCEL.
3. Type a filename.
4. Press ENTER.

Display the Command Screen During Communications

• Press ALT+C.

Display the Terminal Screen
To display the terminal screen without executing an autolog
file, select Terminal from the Options Menu (F5).

Execute a Saved Autolog File
1. Select Autolog from the File Menu (F2).
2. Highlight the name of the autolog file you want to exe-

cute.
3. Press ENTER.

Insert a Line in an Autolog File
1. Move the cursor to the line immediately below where

you want to insert a blank line.

2. Select Insert from the Commands Menu (F3).

Load the Buffer from Within an Autolog File
1. Select Load from the Buffer Menu (F4).
2. Highlight the name of the file you want to load.
3. Press ENTER.
Load the Buffer from Another Drive or Directory
1. Select Load from the Buffer Menu (F4).
2. Highlight the appropriate drive or directory and press

ENTER.
3. Repeat Step 2 until the list box displays the file you want

to load.
4. Highlight the name of the file you want.
5. Press ENTER.

Print the Buffer Contents
1. Select Pri nt from the File Menu (F2).
2. At the Print to : prompt, choose Printer, Screen, or

File.
3. Press ENTER.

Note: If you are printing to a file, remember to specify a
filename.

Transfer a File Manually
1. Select Transfer f i l e from the Options Menu (F5).
2. Highlight the name of the file you want to transfer.
3. Choose Send to transfer a file from your computer to the

host or Receive to transfer a file from the host to your
computer.

4. Choose Xmodem to use the special file transfer protocol or
ASCII to use the ASCII file transfer protocol.

5. If you chose ASCII, choose the appropriate option:
Add 1 i ne feed after carri age return to add a line feed
each time Telecom sends (or receives) a carriage return
character.
Strip 1 ine feed after carriage return to take out line
feeds after carriage return characters.
Straight ASCII transfer to strip all non-ASCII codes
from the file.

6. If necessary, at the Command to start transfer: prompt,
type the command needed to indicate to the host that
your computer is ready to receive the ASCII file.

7. Choose Add carri age return to add a carriage return for
the command in Step 6 if required.

8. Atthe Timeout: prompt, type the number of seconds
you want Telecom to wait.

9. Press ENTER.

Turn the Buffer On and Off

• Select Buffer on or Buffer off from the Options Menu
(F5), depending on whether you want to see the incom-
ing data.
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Text

Attention Diskette Users:
If you are using diskettes to
run DeskMate, you might be
asked to insert another Desk-
Mate diskette. Insert the re-
quested diskette and press
ENTER.

You can say good bye to your typewriter and give your letters, term
papers, and important documents a facelift with DeskMate's Text
application. Use Text for any project for which you would ordinarily
use a typewriter.

You can access Text from the
desktop or from within another
DeskMate application. If you
need more information about
opening DeskMate's applica-
tions, be sure to see the Tech-
niques Box in this article.

When you enter Text, here's
what you see:

Think of the Text screen as a
sheet of typing paper. The dif-
ference is, you don't have to rip
out the paper and throw it away
if you make a mistake. Simply
use a few Text commands to
adjust your document until it is
exactly the way you want it.
Text can even check your spell-
ing.

This article explains some of the
basics of Text and then guides
you through some editing tech-
niques in a fun way. To learn
about all the various features
(or if you have questions about
the tasks described here), re-
member to press FI for
DeskMate's help.

Take a few minutes to do the
tasks in this article, and enjoy!

The Case of the Missing Signature
An eerie shadow looms over the computer; the blinking cursor on the
computer screen is the only movement in the room. Moments pass, and
finally a lone figure faces the screen and begins to type the confession
that (if discovered in time) will save Nellie Tucket's life.

Type Information To whom i t may concern:
, c ,, • • r • ENTER

Type the following information, ENTER
and press the appropriate keys . , , . ., ,
where indicated- ?n the m g h . * 0

H
f
 t J p n l

t
 6 i

1990, I committed the act of
murder against Floyd Fiend.
ENTER
ENTER

If you make mistakes while you
are typing, use the BACKSPACE
key to delete the character to the
left of the cursor or DELETE to
delete the character to the right
of the cursor.

TAB Signed, ENTER
ENTER
TAB Luke Ludicrous
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Luke studies the confession and
decides to make some changes.

Edit Text

Insert Words

1. Move the cursor immedi-
ately before the c in com-
mitted.

2. Type w i l l f u l l y .

3 . Press the space bar.

Use Bold

1. Use the arrow keys to move
the cursor to the beginning
of the confession.

2 . Highlight To whom i t may
concern:

To highlight text, press SHIFT
and the appropriate arrow key.

The text appears in reversed
type.

3 . Select Bold from the Text
Menu (F4).

The text appears in a differ-
ent intensity.

If your printer supports boldface,
the text you highlighted will ap-
pear boldfaced when printed.

Use Text's Spell Checker

Luke is a perfectionist, and if his
confession might be used in a
court of law, he wants the spelling
to be correct.

1. Select Proof from the Edit
Menu (F3).

If you typed Luke's confes-

sion correctly, the message
All words are correct ly
spel led appears.

If a word is misspelled, a
dialog box appears showing
the "unknown" word, the
context in which it is used,
and some possible replace-
ments. For example:

You can choose a word from
the Repl acements box or
move the cursor to the con-
text field and correct the
misspelled word.

2 . Press ENTER.

Now there's just one last change;
a change that could be fatal to
Nellie Tucket.

Remove Text

1. Move the cursor to the be-
ginning of Luke's name.

2 . Highlight the entire name.

3 . Select Cut from the Edit
Menu (F3).

Viola! The condemning name is
erased. (But is it?)

Meanwhile, as Nellie waits on
Death Row, her friend, Sam
Clubs (the man Nellie loves) re-
turns to the scene of the crime to
look for a clue that will lead him
to the real murderer.

Re-insert Text

Finding a locked door in the
gothic structure that was once the
home of Nellie's uncle, Floyd
Fiend, Sam struggles to get the
door open. Once in the room, he
finds the unsigned confession
glaring at him from the computer
screen. His hopes sink. But, sud-
denly Sam remembers there is a
special invisible memory buffer
that stores text that has been re-
moved from a document.

1. Move the cursor to the
space just under Signed.

2 . Select Paste from the Edit
Menu (F3).

Success!! Luke's name magically
appears. Sam has solved the case,
but how does he convince the
police of it? He can't take the
computer to Police Headquar-
ters?

Printing Text
Sam is going to print the confes-
sion. If you have a printer, you
can print the confession, too.

Before you print, be sure that you
have set up your printer prop-
erly, and that paper is loaded.
(Refer to your printer manual.)
Also, be sure you use the Printer
option in DeskMate's Setup Ac-
cessory to specify the type of
printer you are using. See the
"Accessories" article for instruc-
tions on using the Printer option.

1. Select Print from the File
Menu (F2).

A dialog box appears.

Text 69



2. At the Print to: prompt,
choose the Printer button.

3 . Press ENTER.

Lucky for Nellie! Sam has the
evidence to prove her innocence.

Find Just the Right Word

You can be more precise in your
written communication by add-
ing a Thesaurus word-finding
system to your software collec-
tion. The DeskMate Thesaurus
Companion lets you look up and
replace words in a document
you create with DeskMate's Text
application. You can purchase
this product at your local Radio
Shack Store.

Techniques Box

Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.
DELETE deletes the character to the right of the cursor.

Exit the Application

• Press ESC to return to the desktop.

Highlight Text
1. Use the arrow keys to move the cursor to the beginning

of the text you want to highlight.
2. Press SHIFT and the appropriate arrow key(s) to high-

light the text.

Move Around a Dialog Box

• TAB moves the cursor to the next field. (SHIFT+TAB
moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a check box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER.

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press 4 until you highlight
Run, and press ENTER.
A dialog box appears and you can type the application
name at the Program: prompt and, if you wish, the name
of the file you want to open at the Data f i l e : prompt.
Press ENTER to select OK and open the application or file.

Select Menu Options
1. Press a function key (F2-F10).
2. Press ^to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option (for example,
Copy on the Edit Menu (F3)).
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Preview of Other Uses for Text
The uses for Text are almost endless. You can tailor the design of
your page to meet your needs for reports, term papers, advertise-
ments, or letters. Using Text with DeskMate's Draw application, you
can insert pictures you create into your Text documents. In addition,
you can use the addresses you have stored in the Address Book
application to create form letters. Use your imagination.

DeskMate's Text application has lots of additional special features
to meet your needs. Be sure to see the Additional Text Tasks box for
more specific task instructions. And remember, you can press FI for
DeskMate's help any time you need it.

Additional

Add a Field from Address Book
1. Move the cursor to the location where you want to insert

a field from the Address Book.
2. Select Add f i el d from the Layout Menu (F6).
3. Choose the field to insert at the cursor location.
4. Press ENTER.

Cancel Boldface or Underline
1. Highlight the text you want to return to plain type.
2. Select PI ai n from the Text Menu (F4).

Center and Uncenter Text
1. Move the cursor to the line of text you want to center.
2. Select Center or Uncenter from the Text Menu (F4).

Insert New Text

• Press INSERT to toggle between Insert and Overtype
mode. (If Insert is the current mode, a check mark ap-
pears next to the Insert option on the Edit Menu (F3).)
Note: When you are in Insert mode, anything you type is
inserted at the cursor's location. When you are in Over-
type mode, anything you type replaces existing text.

Convert Documents to ASCII

• Select To ASC11 from the File Menu (F2).
Note: If you convert a document into ASCII format, all
word-processing codes (such as boldfacing, head-
ers/footers, indents, and centering), pictures in the doc-
ument, and page setup parameters are removed.

Create a Footer
1. Select Footer from the Layout Menu (F6).
2. Choose the desired option.
3. Press ENTER.

Text Tasks

Create a Header
1.
2.
3.

Select Header from the Layout Menu (F6).
Choose the desired option.
Press ENTER.

Delete a Footer
1.
2.

Select Footer from the Layout Menu (F6).
Select No footer.

Delete a Header
1.

2.

Select Header from the Layout Menu (F6).
Select No header.

Delete a Section of a Document
1.

2.

Highlight the section of your document that you want to
delete.
Select Clear from the Edit Menu (F3).

End a Paae
1.
2.

Type .N.
Press ENTER.

Find Text
1.
2.
3.

4.
5.

Move the cursor to where you want to begin the search.
Select Find from the Search Menu (F5).
At the Search for : prompt, type the characters you want
to find.
Press ENTER.
To find subsequent occurrences of the same text, select
Find next from the Search Menu (F5).

Format a Page Layout
1.

2.
3.
ft

Select Page setup from the File Menu (F2).
Change the desired options.
Press ENTER.
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Additional Text Tasks (Continued)

Hide All Pictures

• Select Hide from the Picture Menu (F7).

Note: Hiding pictures in a document replaces all pictures
with **Picture Located Here**.

Highlight an Entire Document

• Select Select a l l from the Edit Menu (F3).

Indent Text
1. Select Indent from the Text Menu (F4).
2. At the First l ine indent: prompt, type the number of

characters you want to indent the first line of a paragraph
from the document's left margin.

3. At the Left margin indent prompt, type the number of
characters you want to indent the body of the paragraph
from the document's left margin.

4. At the Right margin indent prompt, type the number of
characters you want to indent the body of the paragraph
from the document's right margin.

5. Press ENTER.

Insert a Picture into a Document
1. Follow the instructions in the "Draw" article to cut or

copy a picture to another application.
2. Exit Draw.
3. Open the appropriate Text document.
4. Move the cursor to where you want to place the picture.
5. Select Paste from the Edit Menu (F3).

Insert Another Document into the Document on the
Screen
1. Move the cursor to the place where you want to insert

w* t I \s L 1 1 \s 1 \J \*t\t U I I I w 1 1 L •

2. Select Merge from the File Menu (F3).
3. Highlight the document you want to merge.
4. Press ENTER.

Insert Today's Date in Your Document
1. Move the cursor to the place in your document where

you want the date to appear.
2. Select Today's date from the Layout Menu (F6).
3. Choose the format in which you want the date to appear.
4. Press ENTER.

Move a Picture Within the Same Document
1.

2.
3.

Select the art to be moved.
Select Move from the Picture Menu (F7).

Move the art to a new location in your document.

Print Form Letters

1.

2.

3.

Note: If you are using a diskette system, the document
you want to print and the Address Book file must be on
the same diskette before you attempt to print aform letter.
Select Print form le t te r from the File Menu (F2).
Note: If your document is untitled, you will be prompted
to enter a filename.
Select the list you want to use from the Address Book.
Press ENTER.

Reinsert Deleted Information
1.

2.

Move the cursor to the place in your document where
you want to reinsert text you removed using the Del ete
option.
Select Un-Del ete from the Edit Menu (F3).

Resize a Picture
1.

2.

3.

Place the cursor anywhere on the picture.
Select Size from the Picture Menu (F7).
Change the size of the box as you would in the Draw
application.

Show All Pictures

• Select Show from the Picture Menu (F7).

Substitute Text
1.
2.

3.

4.

5.

Select Substitute from the Search Menu (F5).
At the Search for : prompt, type the text you want to find
and replace, using no more than 30 characters.
At the Repl ace wi th : prompt, type the text you want to
use as a replacement.
Press ENTER.
If the text is found, a dialog box appears asking whether
you want to make the substitution at this particular occur-
rence.
Select YES, NO, or CANCEL.

Underline Text
1.

2.

Highlight the text you want to underline.
Select Underl i ne from the Test Menu (F4).
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Worksheet

Have you been meaning to develop a budget, balance your checkbook,
or prepare a loan amortization plan? With Worksheet, DeskMate's
electronic spreadsheet program, you can do all these things and more!

column numbers. For example,
the first cell in the upper left
corner (highlighted when you
open a worksheet) is referenced
as R1C1. A cell's default size is
10 characters.

Your worksheet consists of 99
rows and 99 columns that inter-
sect to form cells of 10 charac-
ters. (You can change the
default number of characters in
a cell.) You can move the cursor
from cell to cell by using any of
the keyboard arrow keys (or
scrolling arrows if you are using
a mouse).

Worksheet will make organiz-
ing your personal finances sim-
ple. This article explains some
of the basics of Worksheet and
guides you through a handy ex-
ample, creating a home budget.

You can access Worksheet from
the desktop or from within an-
other DeskMate application.
Refer to the Techniques Box in
this article for further informa-
tion.

When you access Worksheet, an
empty worksheet appears. A
worksheet is divided into
numbered rows and columns.
The area where a row and col-
umn intersect is called a cell.
Cells are identified by row and

Column

Attention Diskette Users:
If you are using diskettes to
run DeskMate, you might be
asked to insert another disk-
ette. Insert the new diskette
and press ENTER.

Row Scrolling arrows

Status line
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Let's begin our sample home
budget with a title. To enter this
text, do the following:

1. Highlight cells R2C3 and
R2C4 by pressing the arrow
keys to move the highlight
to R2C3. Then, press SHIFT
+ -» to also highlight R2C4.

Press SHIFT and an arrow key to
highlight consecutive cells.

2 . Select Start text from the
Cells Menu (F6).

3 . Type HOME BUDGET.

BACKSPACE deletes the character
to the left of the cursor.
DELETE deletes the character to
the right of the cursor.

4 . Select End tex t from the
Cells Menu (F6).

Use the Start text and End text
options on the Cells Menu (F6)
when you want to type in text
that is longer than one cell's
length. Otherwise, you can sim-
ply highlight a cell and begin
typing.

1. Move the highlight to cell
R9C1, type GROCERIES, and
press J,.

2 . Using the same procedure,
enter the labels CLOTHES,
MORTGAGE, ELECTRIC, GAS,
CAR, AUTO INSUR. Then, skip
a line (R16C1) and enter
the last three labels Mini-
mum, Maximum, and Total .

Repeat the same procedure to
enter BUDGETED and ACTUAL in
Row 7 for Columns 2 and 3.

Next, let's enter labels to iden-
tify your worksheet's categories.

To right align BUDGETED and AC-
TUAL on your screen, do the fol-
lowing:

1. Highlight both cells.

2 . Select Format from the Cells
Menu (F6).

A dialog box appears.

3 . Choose Right from the
Al i gn option.

4 . Press ENTER.

Now you are ready to enter the
numbers . To enter a number ,
highlight the appropriate cell
and type the number . As you
type the numbers , notice that

decimal points are automati-
cally inserted if you don't insert
them. (For example, if you type
125 the screen displays 125.00.)
Worksheet also automatical ly
aligns the numbers to the right.

To delete all the characters in a
cell or a block of cells, highlight
the cell(s) and press DELETE.

GROCERIES
CLOTHES
MORTGAGE
ELECTRIC
GAS
CAR
AUTOINSUR

250.00
150.00
720.00

65.50
87.00

145.00
60.00

217.17
129.31
720.00

62.35
64.19

145.00
60.00

To tell Worksheet what calcula-
tions you want done, enter for-
mulas where you wan t the
results of the calculations to ap-
pear.

To enter the first formula in this
example, do the following:

1. Highlight cell R19C2.

2 . Select Formul a from the
Cells Menu (F6).

A dialog box appears.

3 . Type the formula SUM(#R8).

4 . Press ENTER.

F™I, ; — i i
Operators: t, - •, ', !

FwtllrittS, (lit M, 01, MS, Kf, IM, 10G, ISX, lift BUI, SSH S i l t » S i t , Ml

DflflD
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The formula SUM(#R8) tells
Worksheet to total all the num-
bers listed from Row 8 to Row
19 in Column 2. The # identifies
this cell as an absolute reference.
(For additional information
about the formulas, operators,
and functions you can use with
Worksheet, refer to the DeskMate
User's Reference.)

The formula does not appear in
the cell, but when the cell is
highlighted the formula can be
seen in the status line. Different
formulas can be entered in other
cells to yield additional results.

Enter the following additional
formulas. (Remember to refer to
the DeskMate User's Reference

for more information about for-
mulas.)

In Cell:
R17C3
R18C3
R19C3

Type Formula:
MIN(#R8)
MAX(#R8)
SUM(#R8)-
(#R17+R18)

After you insert formulas into a
worksheet, you can get the re-
sults of the calculations by se-
lecting Cal cul ate from the Pad
Menu (F4). The answers are dis-
played in the cells that contain
the formulas. If you calculate
our sample worksheet, you get
these results:

Techniques Box

Correct Typing Errors
BACKSPACE deletes the character to the left of the cursor.

DELETE deletes the character to the right of the cursor.

Highlight Consecutive Cells

• Press SHIFT+ J,or t -

Move Around a Dialog Box
• TAB moves the cursor to the next field. (SHIFT+TAB

moves the cursor backward.)

• Arrow keys move the cursor within a group of buttons or
check boxes.

• Space bar chooses an underlined button or check box.
(Space bar also unchecks a check box.)

• ENTER automatically selects OK.

• ESC automatically selects CANCEL.

Open a DeskMate Application

• If the application appears on the desktop, press TAB to
highlight the application, and then press ENTER.
or

• If the application is not on the desktop, press F2 to pull
down the File Menu. Then, press 4until you highlight Run,
and press ENTER.
A dialog box appears and you can type the application
name at the Program: prompt and, if you wish, the name
of the file you want to open at the Data f i l e : prompt.
Press ENTER to select OK and open the application or file.

Select Menu Options
1. Press a function key (F2-F1O).
2. Press 4 to highlight the desired option.
3. Press ENTER.

Note: Sometimes you must highlight information on the
screen before you can use a specific option (for example,
Copy on the Edit Menu (F3)).
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Preview of Other Uses for Worksheet
Use the Worksheet application for any type of report that requires
calculations. In addition to a budget, you might, for example, create
a balance sheet for your business, an amortization schedule, or an
estimated loan repayment schedule, For your convenience, Work-
sheet comes with already created files to help you setup an amorti-
zation schedule (trm.wks) and an estimated loan repayment
schedule (loan.wks).

Be sure to see the Additional Worksheet Task box for more specific
task instructions. Also, remember to press FI for DeskMate's help.

Additional Worksheet Tasks

Add a Column Between Columns
1. Position the highlight to the right of where you want to

add the new column.

2. Select Insert col umn from the Pad Menu (F4).

Add a Row Between Rows
1. Position the highlight below where you want to add the

new row.

2. Select Insert row from the Pad Menu (F4).

Change a Formula
1. Move the highlight to the cell that contains the formula

you want to change.
2. Select Formula from the Cells Menu (F6).
3. Type the new formula.
4. Press ENTER.

Change the Width of One or More Columns
1. Move the highlight to the column whose width you want

to change.
2. Select Col umn width from the Pad Menu (F4).
3. Choose Current to change the highlighted column or

All to change all columns.
4. At the Width: prompt, type the new width.
5. Press ENTER.

Delete an Entire Worksheet
1. Select Select a l l from the Edit Menu (F3).

2. Select Cl ea r from the Edit Menu (F3).

Find a Cell
1. Select Find cell from the Search Menu (F5).
2. At the Row: prompt, type the row number of the cell you

want to find.
3. At the Col umn: prompt, type the column number for the

cell you want to find.
4. Press ENTER.

Find a Label
1. Select Find label from the Search Menu (F5).
2. At the Label: prompt, type the label you want to find.

3. Press ENTER.

Find a Number
1. Select Find number from the Search Menu (F5).
2. At the Number: prompt, type the number you want to find.
3. Press ENTER.
To find subsequent occurrences:

4. Select Fi nd next from the Search Menu (F5).

Input Contents of a Specific Cell before Calculation
1. Select Input from the Cells Menu (F6).
2. At the Field Name: prompt, type a phrase to identify the

cell.
3. At the Field Value: prompt, type the numerical value

you will use most often, or leave the box blank.
4. Press ENTER.

Remove a Column
1. Move the highlight to the column you want to delete.
2. Select Delete column from the Pad Menu (F4).

Remove a Formula
1. Move the highlight to the cell that contains the formula.
2. Select Formula from the Cells Menu (F6).
3. Press BACKSPACE to delete the formula.
4. Press ENTER.

Remove a Row
1. Move the highlight in the row you want to delete.
2. Select Delete row from the Pad Menu (F4).
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Appendix

Data Diskettes
If you have a diskette-based
computer, you can save disk
space by storing your data —
letters, reports, worksheets, and
so on that you create using
DeskMate — on separate disk-
ettes from your application pro-
grams. The procedures that
follow describe how to use data
diskettes with DeskMate.

To prepare a diskette for storing
nothing but data, you format it
as a data diskette. (From the
desktop, you can use the Format
option on the Disk Menu (F4).)
The following sections explain
how to use formatted data disk-
ettes.

One-Drive Diskette-
Based System
To save a file onto a data disk-
ette:

1. Start DeskMate.

2. Open an application, and
create a file.

3. Remove the application
diskette, and insert a data
diskette.

4. Select Save as from the File
Menu.

A dialog box appears.

5. At the Save as: prompt,
type the name you want to
give the file, and press
ENTER.

The file will be saved to this
diskette.

To open an application
and its data file:
1. Start DeskMate.

2. Open an application.

3. Remove the application
diskette from the drive, and
insert the data diskette into
the drive.

4. Select Open from the File
Menu (F2).

A dialog box appears, listing all
the files you can open on the
current diskette.

5. Highlight the file you want
to open, and press ENTER.

Keep the data diskette in the
drive while working on the file
so that you can periodically save
the file to its data diskette.

Two-Drive Diskette-
Based System
To save a file onto a data disk-
ette:

1. Start DeskMate.

2. Insert an application disk-
ette into Drive A and a data
diskette into Drive B.

3. Open the application.

4. Select Save as from the File
Menu (F2).

A dialog box appears.

5. At the Save as: prompt,
type B: and the name you
want to give the file, and
press ENTER.

The file will be saved onto this
diskette.
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Computing is Easier —
with a Hard Disk

Expand the power and mem-
ory of your computer by add-
ing a hard disk. You'll also
enjoy the convenience of run-
ning your DeskMate applica-
tions and files without having
to insert various program
diskettes.

To open an application
and its data file:
1. Start DeskMate.

2. Insert an application disk-
ette into Drive A and the
data diskette into Drive B.

3. Open the application.

4. Select Open from the File
Menu (F2).

A dialog box appears.

5. Highlight Drive B ([B:])
and press ENTER.

Keep the data diskette in Drive
B while working on the file so
that you can periodically save
the file to its data diskette.

Memory
Considerations

If you increase the number of
file buffers or files beyond the
MS-DOS default, you might en-
counter program limitations.

Setting the Dmconfig
File
Dmconfig is a setting that you
can use to tell DeskMate where
to store its configuration files
(files required to retain the cur-
rent DeskMate memory set-
tings), the data file personal.adr
(required by the Address Book
application), and the data file
personal.cal (required by the
Calendar application).

Normally, you do not need to
specify or change the dmconfig
setting. However, there is one
condition that requires that you
set dmconfig:

• If you have a hard disk com-
puter and you rearrange
your files so that they are
stored in directories other
than the default directories,
you need to set dmconfig to
those directories.

To set dmconfig, type the fol-
lowing command at the system
prompt each time you boot up
the system:

set dmconf ig=directory

where directory is the directory
you want dmconfig set to.

Reminder: Always double-
check the spelling of the direc-
tory name. Spelling a name
incorrectly is the same as setting
dmconfig to a nonexistent direc-
tory, an error that causes Desk-
Mate to operate improperly. An
error message appears on the
screen if you misspell a directory
name.

You can place the set dmconfig
command in an autoexec.bat
file. By placing this command in
autoexec.bat, you won't have to
type it each time you boot up
because dmconfig will execute
automatical ly on system
startup.
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Index

accelerator keys, 7, 36
Accessories

Alarm, 25
Calculator, 23
Clipboard, 26-27
Corkboard, 24
To Do List, 25-26
Month, 24
overview, 17
Phone List, 23-24
Setup, 18-21
Spell Checker, 22
Task Switch, 27-28

Address Book application
adding

addresses, 30
existing addresses to

another list, 31
address record, 29
creating additional lists, 31
deleting

addresses, 30
addresses from specialized

lists, 31
dialing phone numbers, 33
entering addresses, 30
finding addresses, 33
formatting mailing labels, 33
illustration of, 29
merging address lists, 33
modifying addresses, 31
other uses, 32
printing lists, labels, or form

letters, 33
status line, 29
storing addresses, 30
techniques box, 32
title bar, 29

viewing
address lists, 31
lists or addresses, 33

Alarm accessory
alarm function for Calendar

application, 34
description of, 25

applications. See also specific
applications

definition of, 6
ESC key for exiting, 8
opening applications, 7, 37
TAB key for selecting from

screen, 6
ASCII documents, converting

from Text application, 71
autolog file. See Telecom

application
B
beginner's lessons

exiting, 16
starting, 9, 16
techniques box for, 16

Calculator accessory, 23
Calendar application. See also

Month accessoiy
accelerator key functions, 36
adding reminders, events,

and occasions, 38
alarm function, 34
changing reminders, events,

and occasions, 38
deleting

calendars, 38
reminders, events, and

occasions, 38

Calendar application (Conr.)
finding

dates, 38
text, 38

illustration of, 34
moving the cursor, 37
multiple calendars, 36
other uses for, 37
printing agendas, 36
scheduling an event, 35
searching for dates, 35-36
uses for, 34

Call command, Telecom
application, 64-65

Clipboard accessory
clearing the entire Clipboard,

27
copying Clipboard informa-

tion, 27
deleting Clipboard entries,

27
overview, 26
saving Clipboard files, 26-27

colors, setting, 19
communicating with online

services. See Telecom
application

Communications Settings,
18-19

configuring your system. See
Setup accessory

copying
diskettes, 42
files, 42

Corkboard accessory, 24
correcting typing errors, 32
cursor, definition of, 6
customizing your desktop,

40-41
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D
data diskettes, 77-78
database management.

See Address Book application;
Filer application

date and time, setting, 20
deleting files, 42-43
DeskMate. See also desktop

beginner's lessons, 9, 16
desktop for, 6
dialog boxes, 8, 9
getting around in, 6-9
help for using, 12-15
list boxes, 8
menus and menu bars, 7-8
methods of learning, 2-3
mouse used with, 10-11
opening applications, 7
uses for, 2

DeskMate User Interface
programs, installing, 43-44

desktop
altered functions after

installation of software, 43
application boxes or buttons

deleting, 45
displaying, 40
redefining, 45
removing boxes from

desktop, 40
changing desktop view, 41
checking disk storage space,

45
controlling appearance of, 45
copying diskettes, 42
customizing your desktop,

40-41
directories

changing, 41
creating, 45
deleting, 45

drives, changing, 41
files

desktop (Cont.)
checking file size, 45
copying, 42
deleting, 42-43
file management, 40
renaming, 45
sorting in tree view, 45

formatting diskettes, 41-42
illustration of, 6, 39
installing other software

programs, 43
moving around the desktop,

6
other uses and tasks, 45
techniques box, 41
updating the screen, 45
using Quick Load, 44

dialog boxes
ESC key for removing, 8
illustration of, 8
moving around in, 8-9

directories
changing, 41
definition of, 40
paths, 44
setting, in dmconfig file, 78
working with, 40-41

disk drives, changing, 41
diskette-based systems

altered functions after in-
stallation of software, 43

data diskettes, 77-78
one-drive systems, 77
two-drive systems, 77-78

diskettes
copying, 42
formatting, 41-42
using Quick Load, 44

dmconfig file, 78
Draw application

aligning objects, 50
birthday card example,

46-48

Draw application (Cont.)
breaking an object into

pieces, 50
canvas view, changing, 50
changing colors, 50
choosing keyboard or mouse,

50
clip art, 50
drawing tools, 46
duplicating pictures, 50
entering text, 48
fill pattern, 50
flipping an area horizontally,

50
inserting pictures in other

applications, 50
line weight and style, 50
making picture pieces an

object, 50
moving items to front or back,

50
other uses, 49
overview, 46
polygonal shapes, changing,

50
printing, 48
resizing pictures, 50
rotating pictures, 50
techniques box, 49

drives, changing, 41

ESC key
exiting applications, 8
removing menus or dialog

boxes, 8

FI key, for getting help, 12
Filer application. See also

Form Setup application
adding records, 52
changing information in

fields, 52
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Filer application (Com.)
copying

layouts, 53
records, 54

counting records, 54
creating

files, 52-53
new layouts, 53

deleting records, 54
finding records, 54
formatting page layouts, 54
other uses, 54
overview, 51
printing

records, 54
reports, 54, 58

sorting records, 54
switching to Form Setup, 54
techniques box, 53
uses for, 51
viewing records in files, 51

files. See also directories
copying, 42
definition of, 40
deleting, 42-43
working with, 40

Form Setup application. See
also Filer application

adding fields
to record layouts, 59
to report layouts, 59
summary fields, 59

boldface and underlining, 59
changing

field attributes, 59
size of fields, 59
size of report layouts, 59

copying layouts, 59
cosmetic text, 57, 59
creating

new record layouts, 56-57
report layouts, 58

Form Setup application (Cont.)
deleting information, 60
format characters, 59
inserting

dates, 60
page numbers, 60

other uses, 59
overview, 55
placing graphics, 60
printing

layouts, 60
reports, 58

resizing pictures, 60
sorting records, 60
switching between layouts, 60
techniques box, 55
Text menu, 60
tips for layouts, 57

formatting diskettes, 41-42
function keys for opening

menus, 7

General Help, 12-13
getting around in DeskMate

dialog boxes, 9
menu bars and menus, 7-8
moving around the desktop,

6
opening "doors," 7
TAB key for, 6

H
Hangman, 61-62
help for DeskMate

General Help, 12-13
Problem Solving Help, 15
Quick Reference Help, 14

installing other programs
altered functions after

installation, 43

installing other programs
(Continued)

DeskMate User Interface
programs, 43-44

non-DeskMate programs, 44
overview, 43

K
keys

accelerator keys, 7
ESC key, 8
FI key, for getting help, 12
function keys for opening

menus, 7
key functions for Corkboard,

24
SHIFT+TAB key for moving

backwards, 6
TAB key for moving around

screen, 6

layouts. See Filer application;
Form Setup application

list boxes
illustration of, 8
use of, 8

lists. See Address Book applica-
tion; Phone List accessory;

To Do List

M
mailing labels. See Address

Book application
memory

dmconfig file, 78
memory considerations, 78

memory-resident programs, 28
menus and menu bars

closing menus, 8
ESC key for removing, 8
opening with function keys,

7
options on, 7
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menus and menu bars (Cont.)
shadowed menu options. 7
use of, 7-8

Menus View, 41
modem

setting up, 18
monitors

monochrome monitors, 19
setting colors for, 19

Month accessory, 24. See also
Calendar application

mouse
reasons for using, 11
setting up, 19-20
techniques box for using, 11
using the mouse, 10

N
notepad. See Corkboard

P
paths, 44
Phone List accessory, 23-24
ports

communications ports, 18
for printers, 20-21
serial port for mouse, 20

Printer Settings, 20-21
printing

from Address Book
application, 33

from Calendar application,
36

contents of buffer from
Telecom application, 67

from Draw application, 48
from Filer application, 54
from Form Setup application,

58,60
from Text application, 70, 72

Problem Solving Help, 15

Quick Load, using, 44
Quick Reference Help, 14

R
records. See Filer application
report layouts. See Form Setup

application

Screen Saver, 21
Send command, Telecom

application, 65
serial ports

communications ports, 18
serial port for mouse, 20

Setup accessoiy
Colors, 19
Communications Settings,

18-19
Date and Time, 20
Mouse Settings, 19-20
overview, 18
Printer Settings, 20-21
Screen Saver, 21

shadowed menu options, 7
SHIFT+TAB for moving back-

wards, 6
specialized lists. See Address

Book application
Spell Checker accessory, 22
spreadsheet. See Worksheet

application
switching between programs,

27-28

TAB key
moving around the desktop,

6
SHIFT+TAB for moving back-

wards, 6
Task Switch accessory, 27-28

Telecom application
autolog file

deleting line from, 67
executing open autolog

files, 65
executing saved autolog
files, 67

inserting lines in, 67
setting up, 64

buffer
deleting contents of, 67
loading, 67
printing contents of, 67
turning on and off, 67

Call command, 64
command screen, displaying,

67
disconnecting the telephone

line, 65
other uses, 66
overview, 63
Send command, 65
setting communication

parameters, 64-65
techniques box, 66
terminal screen, displaying,

67
Transfer command, 67
transferring files manually,

67
Wait command, 65

telephone numbers
dialing, from Address Book,

33
Phone List accessory, 23-24

terminate-and-stay-resident
programs, 28

Text application
adding fields from Address

Book, 71
boldface type, 69
cancelling boldface or

underline, 71
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Text application (Conf.)
centering and uncentering,

71
converting documents to

ASCII, 71
deleting headers, footers, or

sections of documents, 71
editing text, 69-70
ending a page, 71
finding text, 71
footers, 71
formatting page layouts, 71
headers, 71
hiding all pictures, 72
highlighting entire document,

72
inserting

another document, 72
new text, 71
pictures, 72
today's date, 72
words, 69

moving a picture, 72
other uses, 71
overview, 68
printing

form letters, 72
text, 70

Text application (Conf.)
re-inserting

deleted information, 72
text, 69-70

removing text, 69
resizing a picture, 72
screen for, 68
show all pictures, 72
Spell Checker, 69
substitute text, 72
techniques box, 70
Thesaurus Companion, 70
typing, 68
underlining text, 72

Thesaurus Companion, 70
time and date, setting, 20
To Do List accessoiy, 25-26
Transfer command, Telecom
application, 67
transferring files. See Telecom

application
Tree View, 41
tutorials, 16

views for desktop, 41

w
Wait command, Telecom

application, 65
Worksheet application

adding
columns, 76
rows, 76

calculating, 75
changing

formulas, 76
width of columns, 76

deleting entire worksheet,
76

entering numbers, 74
finding

cells, 76
labels, 76
numbers, 76

formulas, 74-75
input contents of specific

cell, 76
labels, 74
other uses, 76
overview, 73
removing

columns, 76
formulas, 76
rows, 76

sample home budget, 74-75
status line, 75
techniques box, 75
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Special Offer Coupons
As a DeskMate owner, you're eligible for special offers from Tandy. You'll use these coupons as your
proof of ownership of DeskMate.

Special Offer Coupon

5
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.

1

Special Offer Coupon
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.

Special Offer Coupon

6
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.

2

Special Offer Coupon
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.

Special Offer Coupon Special Offer Coupon

7
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.

3
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.

Special Offer Coupon

8
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.

4

Special Offer Coupon
Use this coupon to qualify for
special offers to DeskMate own-
ers. The offer announcement
will indicate which specific cou-
pon you need to return. The
specified, original coupon must
be returned. A facsimile or copy
is not acceptable.
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Special Offer Coupon 1
Name:
Address:

City, State,

Phone:

Additional

Zip:

Info:

Special Offer Coupon 5
Name:

Address:,

City, State, Zip:.

Phone:

Additional Info:

Special Offer Coupon 2 Special Offer Coupon 6
Name: Name:
Address: Address:

City, State, Zip:.

Phone:

City, State, Zip:.

Phone:

Additional Info: Additional Info:

Special Offer Coupon 3 Special Offer Coupon 7
Name: Name:
Address: Address:

City, State, Zip:.

Phone:

City, State, Zip:.

Phone:

Additional Info: Additional Info:

Special Offer Coupon 4 Special Offer Coupon 8
Name: Name:

Address: Address:

City, State, Zip:_

Phone:

City, State, Zip:.

Phone:

Additional Info: Additional Info:.
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TERMS AND CONDITIONS OF SALE AND LICENSE OF TANDY COMPUTER EQUIPMENT AND SOFTWARE PURCHASED
FROM RADIO SHACK COMPANY-OWNED COMPUTER CENTERS, RETAIL STORES AND RADIO SHACK FRANCHISEES OR

DEALERS AT THEIR AUTHORIZED LOCATIONS

USA LIMITED WARRANTY
I. CUSTOMER OBLIGATIONS

A. CUSTOMER assumes full responsibility that this computer hardware purchased (the "Equipment"), and any copies of software included with the
Equipment or licensed separately (the "Software") meets the specifications, capacity, capabilities, versatility, and other requirements of CUSTOMER.

B. CUSTOMER assumes full responsibility for the condition and effectiveness of the operating environment in which the Equipment and Software are to
function, and for its installation.

II. LIMITED WARRANTIES AND CONDITIONS OF SALE

A. For a period of ninety (90) calendar days from the date of the Radio Shack sales document received upon purchase of the Equipment. RADIO SHACK
warrants to the original CUSTOMER that the Equipment and the medium upon which the Software is stored is free from manufacturing defects. This
warranty Is only applicable to purchases of Tandy Equipment by the original customer from Radio Shack company-owned computer centers,
retail stores, and Radio Shack franchisees and dealers at their authorized locations. The warranty is void if the Equipment or Software has been
subjected to improper or abnormal use. If a manufacturing defect is discovered during the stated warranty period, the defective Equipment must be
returned to a Radio Shack Computer Center, a Radio Shack retail store, a participating Radio Shack franchisee or a participating Radio Shack dealer
for repair, along with a copy of the sales document or lease agreement. The original CUSTOMER'S sole and exclusive remedy in the event of a defect
is limited to the correction of the defect by repair, replacement, or refund of the purchase price, at RADIO SHACK'S election and sole expense.
RADIO SHACK has no obligation to replace or repair expendable items.

B. RADIO SHACK makes no warranty as to the design, capability, capacity, or suitability for use of the Software, except as provided in this paragraph.
Software is licensed on an "AS IS" basis, without warranty. The original CUSTOMER'S exclusive remedy, in the event of a Software manufacturing
defect, is its repair or replacement within thirty (30) calendar days of the date of the Radio Shack sales document received upon license of the
Software. The defective Software shall be returned to a Radio Shack Computer Center, a Radio Shack retail store, a participating Radio Shack
franchisee or Radio Shack dealer along with the sales document.

C. Except as provided herein no employee, agent, franchisee, dealer or other person is authorized to give any warranties of any nature on behalf of
RADIO SHACK.

D. EXCEPT AS PROVIDED HEREIN, RADIO SHACK MAKES NO EXPRESS WARRANTIES, AND ANY IMPLIED WARRANTY OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE IS LIMITED IN ITS DURATION TO THE DURATION OF THE WRITTEN LIMITED WARRANTIES SET FORTH
HEREIN.

E. Some states do not allow limitations on how long an implied warranty lasts, so the above limitation(s) may not apply to CUSTOMER.

III. LIMITATION OF LIABILITY

A. EXCEPT AS PROVIDED HEREIN, RADIO SHACK SHALL HAVE NO LIABILITY OR RESPONSIBILITY TO CUSTOMER OR ANY OTHER PERSON OR
ENTITY WITH RESPECT TO ANY LIABILITY, LOSS OR DAMAGE CAUSED OR ALLEGED TO BE CAUSED DIRECTLY OR INDIRECTLY BY
"EQUIPMENT" OR "SOFTWARE" SOLD, LEASED, LICENSED OR FURNISHED BY RADIO SHACK, INCLUDING, BUT NOT LIMITED TO, ANY
INTERRUPTION OF SERVICE, LOSS OF BUSINESS OR ANTICIPATORY PROFITS OR CONSEQUENTIAL DAMAGES RESULTING FROM THE USE OR
OPERATION OF THE "EQUIPMENT" OR "SOFTWARE." IN NO EVENT SHALL RADIO SHACK BE LIABLE FOR LOSS OF PROFITS, OR ANY
INDIRECT, SPECIAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF ANY BREACH OF THIS WARRANTY OR IN ANY MANNER ARISING OUT OF
OR CONNECTED WITH THE SALE, LEASE, LICENSE, USE OR ANTICIPATED USE OF THE "EQUIPMENT" OR "SOFTWARE."
NOTWITHSTANDING THE ABOVE LIMITATIONS AND WARRANTIES, RADIO SHACK'S LIABILITY HEREUNDER FOR DAMAGES INCURRED BY
CUSTOMER OR OTHERS SHALL NOT EXCEED THE AMOUNT PAID BY CUSTOMER FOR THE PARTICULAR "EQUIPMENT" OR "SOFTWARE"
INVOLVED.

B. RADIO SHACK shall not be liable for any damages caused by delay in delivering or furnishing Equipment and/or Software.
C. No action arising out of any claimed breach of this Warranty or transactions under this Warranty may be brought more than two (2) years after the

cause of action has accrued or more than four (4) years after the date of the Radio Shack sales document for the Equipment or Software, whichever
first occurs.

D. Some states do not allow the limitation or exclusion of incidental or consequential damages, so the above limitation(s) or exclusion(s) may not apply
to CUSTOMER.

IV. SOFTWARE LICENSE

RADIO SHACK grants to CUSTOMER a non-exclusive, paid-up license to use the TANDY Software on one computer, subject to the following provisions:
A. Except as otherwise provided in this Software License, applicable copyright laws shall apply to the Software.
B. Title to the medium on which the Software is recorded (cassette and/or diskette) or stored (ROM) is transferred to CUSTOMER, but not title to the

Software.
C. CUSTOMER may use Software on a multiuser or network system only if either, the Software is expressly labeled to be for use on a multiuser or

network system, or one copy of this software is purchased for each node or terminal on which Software is to be used simultaneously.
D. CUSTOMER shall not use, make, manufacture, or reproduce copies of Software except for use on one computer and as is specifically provided in

this Software License. Customer is expressly prohibited from disassembling the Software.
E. CUSTOMER is permitted to make additional copies of the Software only for backup or archival purposes or if additional copies are required in the

operation of one computer with the Software, but only to the extent the Software allows a backup copy to be made. However, for TRSDOS Software,
CUSTOMER is permitted to make a limited number of additional copies for CUSTOMER'S own use.

F. CUSTOMER may resell or distribute unmodified copies of the Software provided CUSTOMER has purchased one copy of the Software for each one
sold or distributed. The provisions of this Software License shall also be applicable to third parties receiving copies of the Software from
CUSTOMER.

G. All copyright notices shall be retained on all copies of the Software.

V. APPLICABILITY OF WARRANTY

A. The terms and conditions of this Warranty are applicable as between RADIO SHACK and CUSTOMER to either a sale of the Equipment and/or
Software License to CUSTOMER or to a transaction whereby Radio Shack sells or conveys such Equipment to a third party for lease to CUSTOMER.

B. The limitations of liability and Warranty provisions herein shall inure to the benefit of RADIO SHACK, the author, owner and or licensor of the
Software and any manufacturer of the Equipment sold by Radio Shack.

VI. STATE LAW RIGHTS

The warranties granted herein give the original CUSTOMER specific legal rights, and the original CUSTOMER may have other rights which vary from
state to state.
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